Reviewed-by: Lyude Paul <lyude@xxxxxxxxxx> On Tue, 2019-10-15 at 16:34 +0200, Thierry Reding wrote: > From: Thierry Reding <treding@xxxxxxxxxx> > > Add a helper that checks for the fast training capability given the DPCD > receiver capabilities blob. > > Signed-off-by: Thierry Reding <treding@xxxxxxxxxx> > --- > include/drm/drm_dp_helper.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h > index 52ff1f24a24d..def3b3a543a2 100644 > --- a/include/drm/drm_dp_helper.h > +++ b/include/drm/drm_dp_helper.h > @@ -1211,6 +1211,13 @@ drm_dp_enhanced_frame_cap(const u8 > dpcd[DP_RECEIVER_CAP_SIZE]) > (dpcd[DP_MAX_LANE_COUNT] & DP_ENHANCED_FRAME_CAP); > } > > +static inline bool > +drm_dp_fast_training_cap(const u8 dpcd[DP_RECEIVER_CAP_SIZE]) > +{ > + return dpcd[DP_DPCD_REV] >= 0x11 && > + (dpcd[DP_MAX_DOWNSPREAD] & DP_NO_AUX_HANDSHAKE_LINK_TRAINING); > +} > + > static inline bool > drm_dp_tps3_supported(const u8 dpcd[DP_RECEIVER_CAP_SIZE]) > { -- Cheers, Lyude Paul _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel