On Fri, Aug 16, 2019 at 09:11:31PM +0200, Sam Ravnborg wrote: > Hi Laurent. > > On Fri, Aug 16, 2019 at 09:39:05PM +0300, Laurent Pinchart wrote: > > Hi Sam, > > > > On Fri, Aug 16, 2019 at 07:31:05PM +0200, Sam Ravnborg wrote: > > > Hi Laurent > > > > > > Thanks for beating me on this! > > > > > > On Fri, Aug 16, 2019 at 03:22:27PM +0300, Laurent Pinchart wrote: > > > > Standard DRM panel drivers for several panels used by omapfb2 are now > > > > available. Their module name clashes with the modules from > > > > drivers/gpu/drm/omapdrm/displays/, part of the deprecated omapfb2 fbdev > > > > driver. As omapfb2 can only be compiled when the omapdrm driver is > > > > disabled, and the DRM panel drivers are useless in that case, make the > > > > omapfb2 panels depend on the standard DRM panels being disabled to fix > > > > the name clash. > > > > > > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > > --- > > > > drivers/video/fbdev/omap2/omapfb/displays/Kconfig | 5 +++++ > > > > 1 file changed, 5 insertions(+) > > > > > > > > diff --git a/drivers/video/fbdev/omap2/omapfb/displays/Kconfig b/drivers/video/fbdev/omap2/omapfb/displays/Kconfig > > > > index 8c1c5a4cfe18..744416dc530e 100644 > > > > --- a/drivers/video/fbdev/omap2/omapfb/displays/Kconfig > > > > +++ b/drivers/video/fbdev/omap2/omapfb/displays/Kconfig > > > > @@ -49,6 +49,7 @@ config FB_OMAP2_PANEL_DSI_CM > > > > config FB_OMAP2_PANEL_SONY_ACX565AKM > > > > tristate "ACX565AKM Panel" > > > > depends on SPI && BACKLIGHT_CLASS_DEVICE > > > > + depends on DRM_PANEL_SONY_ACX565AKM = n > > > > > > Would: > > > depends on !DRM_PANEL_SONY_ACX565AKM > > > > > > do the same? > > > > > > Example: > > > config FB_INTEL > > > tristate "Intel 830M/845G/852GM/855GM/865G/915G/945G/945GM/965G/965GM support" > > > depends on FB && PCI && X86 && AGP_INTEL && EXPERT > > > ... > > > depends on !DRM_I915 > > > > > > > > > DRM_915 is a tristate symbol. > > > > > > It is maybe bikeshedding, but the !<SYMBOL> seems more logical/readable to me. > > > > The two are equivalent as far as I can tell, so I'm fine with !<SYMBOL>. > > Would you change that when applying, or should I send a v2 ? > > I failed to convince myself they are equivalent. > > From kconfig-languae.rst: > > " > '!' <expr> (6) > (6) Returns the result of (2-/expr/). > > An expression can have a value of 'n', 'm' or 'y' (or 0, 1, 2 > respectively for calculations). A menu entry becomes visible when its > expression evaluates to 'm' or 'y'. > " > > So !<SYMBOL> equals 1 for m and 0 for y. If I get it right. > > My testing was not fully conclusive. > > So I left it as is. > Added a few Fixes: etc. tags. > Applied and pushed to drm-misc-next. > > Ohh, and dim came to my rescue. My Fixes: syntax was wrong but it was > caught in my "dim push" - nice. Aside: dim fixes and dim cite should generate conformant commit citations. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel