On Mon, Jul 22, 2019 at 8:15 AM Alyssa Rosenzweig <alyssa@xxxxxxxxxxxxx> wrote: > > > #define PANFROST_BO_NOEXEC 1 > > +#define PANFROST_BO_HEAP 2 > > Bikeshedding, but I don't like this name. There are, I think, multiple > GPU-mapped buffers (at least in Panfrost -- I don't know how the blob > manages memory) that can be considered heaps of sorts. Some of those are > just regular old BOs. Well, I had 'nomap' which reflected exactly what the kernel would do to the BO and some folks didn't like that either. Granted, exactly what is not mapped wasn't that clear. It's really a question of give userspace exactly what it asks for or tell the kernel how the BO is going to be used and it will decide the details (which could change). It's similar to asking for a linear buffer vs. scanout buffer. > What makes these special is that they're growable. Calling it "heap" is > okay inside the kernel, but for the UABI, I'd prefer an explicit > "PANFROST_BO_GROWABLE(_HEAP)" to make it obvious what's going on. IMO, 'growable' means the BO is one size and then grows to a new size. But we're not resizing the BO, but rather just delaying the GPU mapping and sparsely mapping it. Rob _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel