Am 18.07.19 um 18:15 schrieb Sam Ravnborg: > drm_file used drm_magic_t from uapi/drm/drm.h. > This is a simple unsigned int. > Just opencode it as such to break the dependency from this header file > to uapi. Mhm, why do you want to remove UAPI dependency here in the first place? I mean the type can't change because it is UAPI, but it is rather bad for a documentation point of view. Christian. > > Signed-off-by: Sam Ravnborg <sam@xxxxxxxxxxxx> > Suggested-by: Daniel Vetter <daniel.vetter@xxxxxxxx> > Cc: Sean Paul <seanpaul@xxxxxxxxxxxx> > Cc: Liviu Dudau <Liviu.Dudau@xxxxxxx> > Cc: Chris Wilson <chris@xxxxxxxxxxxxxxxxxx> > Cc: Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxxxx> > Cc: Maxime Ripard <maxime.ripard@xxxxxxxxxxx> > Cc: David Airlie <airlied@xxxxxxxx> > Cc: Daniel Vetter <daniel@xxxxxxxx> > Cc: Jani Nikula <jani.nikula@xxxxxxxxx> > Cc: Eric Anholt <eric@xxxxxxxxxx> > --- > include/drm/drm_file.h | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/include/drm/drm_file.h b/include/drm/drm_file.h > index 67af60bb527a..046cd1bf91eb 100644 > --- a/include/drm/drm_file.h > +++ b/include/drm/drm_file.h > @@ -34,8 +34,6 @@ > #include <linux/completion.h> > #include <linux/idr.h> > > -#include <uapi/drm/drm.h> > - > #include <drm/drm_prime.h> > > struct dma_fence; > @@ -227,7 +225,7 @@ struct drm_file { > struct pid *pid; > > /** @magic: Authentication magic, see @authenticated. */ > - drm_magic_t magic; > + unsigned int magic; > > /** > * @lhead: _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel