On Fri, Jul 12, 2019 at 5:40 AM Arnd Bergmann <arnd@xxxxxxxx> wrote: > > clang complains that 'false' is a not a pointer: > > drivers/gpu/drm/amd/amdgpu/../display/dc/dcn20/dcn20_resource.c:2428:10: error: expression which evaluates to zero treated as a null pointer constant of type 'struct pipe_ctx *' [-Werror,-Wnon-literal-null-conversion] > return false; > > Changing it to 'NULL' looks like the right thing that will shut up > the warning and make it easier to read, while not changing behavior. > > Fixes: 7ed4e6352c16 ("drm/amd/display: Add DCN2 HW Sequencer and Resource") > Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx> Applied. Thanks! Alex > --- > drivers/gpu/drm/amd/display/dc/dcn20/dcn20_resource.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_resource.c b/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_resource.c > index 70ac8a95d2db..66aa414ad38f 100644 > --- a/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_resource.c > +++ b/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_resource.c > @@ -2425,7 +2425,7 @@ struct pipe_ctx *dcn20_acquire_idle_pipe_for_layer( > ASSERT(0); > > if (!idle_pipe) > - return false; > + return NULL; > > idle_pipe->stream = head_pipe->stream; > idle_pipe->stream_res.tg = head_pipe->stream_res.tg; > -- > 2.20.0 > > _______________________________________________ > dri-devel mailing list > dri-devel@xxxxxxxxxxxxxxxxxxxxx > https://lists.freedesktop.org/mailman/listinfo/dri-devel _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel