On Fri, May 17, 2019 at 11:22 AM Stephen Boyd <sboyd@xxxxxxxxxx> wrote: > > Quoting Brendan Higgins (2019-05-14 15:17:10) > > diff --git a/kernel/sysctl-test.c b/kernel/sysctl-test.c > > new file mode 100644 > > index 0000000000000..fe0f2bae66085 > > --- /dev/null > > +++ b/kernel/sysctl-test.c > > @@ -0,0 +1,293 @@ > > +// SPDX-License-Identifier: GPL-2.0 > > +/* > > + * KUnit test of proc sysctl. > > + */ > > + > > +#include <kunit/test.h> > > +#include <linux/printk.h> > > Is this include used? Deleted. > > > +#include <linux/sysctl.h> > > +#include <linux/uaccess.h> > > Is this include used? Deleted. > > > + > > + > > +static void sysctl_test_dointvec_happy_single_negative(struct kunit *test) > > +{ > > + struct ctl_table table = { > > + .procname = "foo", > > + .data = &test_data.int_0001, > > + .maxlen = sizeof(int), > > + .mode = 0644, > > + .proc_handler = proc_dointvec, > > + .extra1 = &i_zero, > > + .extra2 = &i_one_hundred, > > + }; > > + char input[] = "-9"; > > + size_t len = sizeof(input) - 1; > > + loff_t pos = 0; > > + > > + table.data = kunit_kzalloc(test, sizeof(int), GFP_USER); > > + KUNIT_EXPECT_EQ(test, 0, proc_dointvec(&table, 1, input, &len, &pos)); > > + KUNIT_EXPECT_EQ(test, sizeof(input) - 1, len); > > + KUNIT_EXPECT_EQ(test, sizeof(input) - 1, pos); > > + KUNIT_EXPECT_EQ(test, -9, *(int *)table.data); > > Is the casting necessary? Or can the macro do a type coercion of the > second parameter based on the first type? Data field is defined as void* so I believe casting is necessary to dereference it as a pointer to an array of ints. I don't think the macro should do any type coercion that == operator wouldn't do. I did change the cast to make it more clear that it's a pointer to an array of ints being dereferenced. > > > +} > > + > > +static void sysctl_test_dointvec_single_less_int_min(struct kunit *test) > > +{ > > + struct ctl_table table = { > > + .procname = "foo", > > + .data = &test_data.int_0001, > > + .maxlen = sizeof(int), > > + .mode = 0644, > > + .proc_handler = proc_dointvec, > > + .extra1 = &i_zero, > > + .extra2 = &i_one_hundred, > > + }; > > + char input[32]; > > + size_t len = sizeof(input) - 1; > > + loff_t pos = 0; > > + unsigned long abs_of_less_than_min = (unsigned long)INT_MAX > > + - (INT_MAX + INT_MIN) + 1; > > + > > + KUNIT_EXPECT_LT(test, > > + snprintf(input, sizeof(input), "-%lu", > > + abs_of_less_than_min), > > + sizeof(input)); > > + > > + table.data = kunit_kzalloc(test, sizeof(int), GFP_USER); > > + KUNIT_EXPECT_EQ(test, -EINVAL, > > + proc_dointvec(&table, 1, input, &len, &pos)); > > + KUNIT_EXPECT_EQ(test, sizeof(input) - 1, len); > > + KUNIT_EXPECT_EQ(test, 0, *(int *)table.data); > > +} > > + > > +static void sysctl_test_dointvec_single_greater_int_max(struct kunit *test) > > +{ > > + struct ctl_table table = { > > + .procname = "foo", > > + .data = &test_data.int_0001, > > + .maxlen = sizeof(int), > > + .mode = 0644, > > + .proc_handler = proc_dointvec, > > + .extra1 = &i_zero, > > + .extra2 = &i_one_hundred, > > + }; > > + char input[32]; > > + size_t len = sizeof(input) - 1; > > + loff_t pos = 0; > > + unsigned long greater_than_max = (unsigned long)INT_MAX + 1; > > + > > + KUNIT_EXPECT_GT(test, greater_than_max, INT_MAX); > > + KUNIT_EXPECT_LT(test, snprintf(input, sizeof(input), "%lu", > > + greater_than_max), > > + sizeof(input)); > > + table.data = kunit_kzalloc(test, sizeof(int), GFP_USER); > > + KUNIT_EXPECT_EQ(test, -EINVAL, > > + proc_dointvec(&table, 1, input, &len, &pos)); > > + KUNIT_EXPECT_EQ(test, sizeof(input) - 1, len); > > + KUNIT_EXPECT_EQ(test, 0, *(int *)table.data); > > +} > > + > > +static int sysctl_test_init(struct kunit *test) > > +{ > > + return 0; > > +} > > + > > +/* > > + * This is run once after each test case, see the comment on example_test_module > > + * for more information. > > + */ > > +static void sysctl_test_exit(struct kunit *test) > > +{ > > +} > Can the above two be omitted? If they can be empty sometimes it would be > nice to avoid the extra symbols and code by letting them be assigned to > NULL in the kunit_module. Deleted. > > > + > > +/* > > + * Here we make a list of all the test cases we want to add to the test module > > + * below. > > + */ > > +static struct kunit_case sysctl_test_cases[] = { > > + /* > > + * This is a helper to create a test case object from a test case > > + * function; its exact function is not important to understand how to > > + * use KUnit, just know that this is how you associate test cases with a > > + * test module. > > + */ > > + KUNIT_CASE(sysctl_test_dointvec_null_tbl_data), > > + KUNIT_CASE(sysctl_test_dointvec_table_maxlen_unset), > > + KUNIT_CASE(sysctl_test_dointvec_table_len_is_zero), > > + KUNIT_CASE(sysctl_test_dointvec_table_read_but_position_set), > > + KUNIT_CASE(sysctl_test_dointvec_happy_single_positive), > > + KUNIT_CASE(sysctl_test_dointvec_happy_single_negative), > > + KUNIT_CASE(sysctl_test_dointvec_single_less_int_min), > > + KUNIT_CASE(sysctl_test_dointvec_single_greater_int_max), > > + {}, > > +}; > > + > > +/* > > + * This defines a suite or grouping of tests. > > + * > > + * Test cases are defined as belonging to the suite by adding them to > > + * `test_cases`. > > + * > > + * Often it is desirable to run some function which will set up things which > > + * will be used by every test; this is accomplished with an `init` function > > + * which runs before each test case is invoked. Similarly, an `exit` function > > + * may be specified which runs after every test case and can be used to for > > + * cleanup. For clarity, running tests in a test module would behave as follows: > > + * > > + * module.init(test); > > + * module.test_case[0](test); > > + * module.exit(test); > > + * module.init(test); > > + * module.test_case[1](test); > > + * module.exit(test); > > + * ...; > > This comment (and the one above for "this is a helper") looks generic > and should probably only be in some documentation somewhere and not for > a sysctl test? > Deleted. > > + */ > > +static struct kunit_module sysctl_test_module = { > > + .name = "sysctl_test", > > + .init = sysctl_test_init, > > + .exit = sysctl_test_exit, > > + .test_cases = sysctl_test_cases, > > +}; > > + > > +/* > > + * This registers the above test module telling KUnit that this is a suite of > > + * tests that need to be run. > > + */ > > Same comment about generic comment. > Deleted. > > +module_test(sysctl_test_module); > > diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug > > index d5a4a4036d2f8..772af4ec70111 100644 > > --- a/lib/Kconfig.debug > > +++ b/lib/Kconfig.debug > > @@ -1908,6 +1908,12 @@ config TEST_SYSCTL > > > > If unsure, say N. > > > > +config SYSCTL_KUNIT_TEST > > + bool "KUnit test for sysctl" > > Why not tristate? > I don't believe KUnit as a module is currently supported. > > + depends on KUNIT > > + help > > + Enables KUnit sysctl test. > > + _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel