On Mon, Nov 19, 2018 at 04:30:37PM +0530, Jagan Teki wrote: > On Mon, Nov 19, 2018 at 2:00 PM Maxime Ripard <maxime.ripard@xxxxxxxxxxx> wrote: > > > > On Fri, Nov 16, 2018 at 10:09:07PM +0530, Jagan Teki wrote: > > > Burst mode display timings are different from convectional > > > video mode so update the horizontal and vertical timings. > > > > > > Reference code taken from BSP (from linux-sunxi/ > > > drivers/video/sunxi/disp2/disp/de/lowlevel_sun50iw1/de_dsi.c) > > > > > > dsi_hsa = 0; > > > dsi_hbp = 0; > > > dsi_hact = x*dsi_pixel_bits[format]/8; > > > dsi_hblk = dsi_hact; > > > dsi_hfp = 0; > > > dsi_vblk = 0; > > > > > > Signed-off-by: Jagan Teki <jagan@xxxxxxxxxxxxxxxxxxxx> > > > > How is that matching the code you have in the rest of your patch? > > + if (device->mode_flags & MIPI_DSI_MODE_VIDEO_BURST) > + timings.hblk = (mode->hdisplay * Bpp); > + else > + sun6i_dsi_get_timings(dsi, mode, &timings); > > It's again your request to "keep the couple of function to make more > readable" That function in particular doesn't make it much more readable, but more importantly, your commit log doesn't match what you code does. Maxime -- Maxime Ripard, Bootlin Embedded Linux and Kernel engineering https://bootlin.com
Attachment:
signature.asc
Description: PGP signature
_______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel