On Tue, May 10, 2022 at 05:23:09PM -0700, Jacob Pan wrote: > > > diff --git a/include/linux/intel-iommu.h b/include/linux/intel-iommu.h > > > index 5af24befc9f1..55845a8c4f4d 100644 > > > +++ b/include/linux/intel-iommu.h > > > @@ -627,6 +627,7 @@ struct device_domain_info { > > > struct intel_iommu *iommu; /* IOMMU used by this device */ > > > struct dmar_domain *domain; /* pointer to domain */ > > > struct pasid_table *pasid_table; /* pasid table */ > > > + ioasid_t pasid; /* DMA request with PASID */ > > > > And this seems wrong - the DMA API is not the only user of > > attach_dev_pasid, so there should not be any global pasid for the > > device. > > > True but the attach_dev_pasid() op is domain type specific. i.e. DMA API > has its own attach_dev_pasid which is different than sva domain > attach_dev_pasid(). Huh? The intel driver shares the same ops between UNMANAGED and DMA - and in general I do not think we should be putting special knowledge about the DMA domains in the drivers. Drivers should continue to treat them identically to UNMANAGED. > device_domain_info is only used by DMA API. Huh? > > I suspect this should be a counter of # of pasid domains attached so > > that the special flush logic triggers > > > This field is only used for devTLB, so it is per domain-device. struct > device_domain_info is allocated per device-domain as well. Sorry, I might > have totally missed your point. You can't store a single pasid in the driver like this, since the only thing it does is trigger the flush logic just count how many pasids are used by the device-domain and trigger pasid flush if any pasids are attached > > And rely on the core code to worry about assigning only one domain per > > pasid - this should really be a 'set' function. > > Yes, in this set the core code (in dma-iommu.c) only assign one PASID per > DMA domain type. > > Are you suggesting the dma-iommu API should be called > iommu_set_dma_pasid instead of iommu_attach_dma_pasid? No that API is Ok - the driver ops API should be 'set' not attach/detach Jason