Hi Jason, On Tue, 10 May 2022 20:21:21 -0300, Jason Gunthorpe <jgg@xxxxxxxxxx> wrote: > On Tue, May 10, 2022 at 02:07:01PM -0700, Jacob Pan wrote: > > +static int intel_iommu_attach_dev_pasid(struct iommu_domain *domain, > > + struct device *dev, > > + ioasid_t pasid) > > +{ > > + struct device_domain_info *info = dev_iommu_priv_get(dev); > > + struct dmar_domain *dmar_domain = to_dmar_domain(domain); > > + struct intel_iommu *iommu = info->iommu; > > + unsigned long flags; > > + int ret = 0; > > + > > + if (!sm_supported(iommu) || !info) > > + return -ENODEV; > > + > > + spin_lock_irqsave(&device_domain_lock, flags); > > + /* > > + * If the same device already has a PASID attached, just > > return. > > + * DMA layer will return the PASID value to the caller. > > + */ > > + if (pasid != PASID_RID2PASID && info->pasid) { > > Why check for PASID == 0 like this? Shouldn't pasid == 0 be rejected > as an invalid argument? Right, I was planning on reuse the attach function for RIDPASID as clean up, but didn't include here. Will fix. > > > + if (info->pasid == pasid) > > + ret = 0; > > Doesn't this need to check that the current domain is the requested > domain as well? How can this happen anyhow - isn't it an error to > double attach? > > > diff --git a/include/linux/intel-iommu.h b/include/linux/intel-iommu.h > > index 5af24befc9f1..55845a8c4f4d 100644 > > +++ b/include/linux/intel-iommu.h > > @@ -627,6 +627,7 @@ struct device_domain_info { > > struct intel_iommu *iommu; /* IOMMU used by this device */ > > struct dmar_domain *domain; /* pointer to domain */ > > struct pasid_table *pasid_table; /* pasid table */ > > + ioasid_t pasid; /* DMA request with PASID */ > > And this seems wrong - the DMA API is not the only user of > attach_dev_pasid, so there should not be any global pasid for the > device. > True but the attach_dev_pasid() op is domain type specific. i.e. DMA API has its own attach_dev_pasid which is different than sva domain attach_dev_pasid(). device_domain_info is only used by DMA API. > I suspect this should be a counter of # of pasid domains attached so > that the special flush logic triggers > This field is only used for devTLB, so it is per domain-device. struct device_domain_info is allocated per device-domain as well. Sorry, I might have totally missed your point. > And rely on the core code to worry about assigning only one domain per > pasid - this should really be a 'set' function. > Yes, in this set the core code (in dma-iommu.c) only assign one PASID per DMA domain type. Are you suggesting the dma-iommu API should be called iommu_set_dma_pasid instead of iommu_attach_dma_pasid? Thanks a lot for the quick review! Jacob