On 21-05-19, 09:16, Peter Ujfalusi wrote: > On 21/05/2019 8.04, Vinod Koul wrote: > > On 14-05-19, 11:09, Peter Ujfalusi wrote: > >> return vchan_tx_prep(&echan->vchan, &edesc->vdesc, tx_flags); > >> @@ -1801,6 +1804,20 @@ static enum dma_status edma_tx_status(struct dma_chan *chan, > >> unsigned long flags; > >> > >> ret = dma_cookie_status(chan, cookie, txstate); > >> + > >> + if (ret != DMA_COMPLETE && echan->edesc && !echan->edesc->cyclic) { > >> + struct edma_cc *ecc = echan->ecc; > >> + int channel = EDMA_CHAN_SLOT(echan->ch_num); > >> + int j = (channel >> 5); > >> + unsigned int mask = BIT(channel & 0x1f); > > > > GENMASK or define a macro instead of a magic number? > > So it is better to change the other places first from where I have just > copied this. That would be nice as well :) -- ~Vinod