We had kept this as a part of blk-types.h because we saw some other functions trying to do similar things inside this file (op_is_write/flush/discard). But it should be okay for us to move it to blk-mq.h if that’s the right way. Thank you, Nitesh Shetty On Mon, Aug 14, 2023 at 8:28 PM Bart Van Assche <bvanassche@xxxxxxx> wrote: > > On 8/14/23 05:18, Nitesh Shetty wrote: > > On 23/08/11 02:25PM, Bart Van Assche wrote: > >> On 8/11/23 03:52, Nitesh Shetty wrote: > >>> diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h > >>> index 0bad62cca3d0..de0ad7a0d571 100644 > >>> +static inline bool op_is_copy(blk_opf_t op) > >>> +{ > >>> + return ((op & REQ_OP_MASK) == REQ_OP_COPY_SRC || > >>> + (op & REQ_OP_MASK) == REQ_OP_COPY_DST); > >>> +} > >>> + > >> > >> The above function should be moved into include/linux/blk-mq.h below the > >> definition of req_op() such that it can use req_op() instead of > >> open-coding it. > >> > > We use this later for dm patches(patch 9) as well, and we don't have > > request at > > that time. > > My understanding is that include/linux/blk_types.h should only contain > data types and constants and hence that inline functions like > op_is_copy() should be moved elsewhere. > > Bart. > -- dm-devel mailing list dm-devel@xxxxxxxxxx https://listman.redhat.com/mailman/listinfo/dm-devel