Re: [PATCH v14 02/11] Add infrastructure for copy offload in block and request layer.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 8/14/23 05:18, Nitesh Shetty wrote:
On 23/08/11 02:25PM, Bart Van Assche wrote:
On 8/11/23 03:52, Nitesh Shetty wrote:
diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
index 0bad62cca3d0..de0ad7a0d571 100644
+static inline bool op_is_copy(blk_opf_t op)
+{
+    return ((op & REQ_OP_MASK) == REQ_OP_COPY_SRC ||
+        (op & REQ_OP_MASK) == REQ_OP_COPY_DST);
+}
+

The above function should be moved into include/linux/blk-mq.h below the
definition of req_op() such that it can use req_op() instead of open-coding it.

We use this later for dm patches(patch 9) as well, and we don't have request at
that time.

My understanding is that include/linux/blk_types.h should only contain
data types and constants and hence that inline functions like
op_is_copy() should be moved elsewhere.

Bart.

--
dm-devel mailing list
dm-devel@xxxxxxxxxx
https://listman.redhat.com/mailman/listinfo/dm-devel




[Index of Archives]     [DM Crypt]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Packaging]     [Fedora SELinux]     [Yosemite Discussion]     [KDE Users]     [Fedora Docs]

  Powered by Linux