On Tue, Mar 09 2010 at 3:41am -0500, Mikulas Patocka <mpatocka@xxxxxxxxxx> wrote: > > You can see the edits here: > > http://people.redhat.com/msnitzer/patches/multisnap/kernel/2.6.33/r16a/r16_edits.patch > > > > Boils down to: > > * use __func__ rather than hardcoding the function name > > - this fixed ~3 inconsistencies (incorrect function names) and should > > help if/when we do any function renaming in later phases of review > > It consumes one more stack word for every function where this conversion > was performed ... I don't know if it's worth it ... likely it doesn't > matter. > > The problem here is that GCC is preallocating the space for all outgoing > arguments in the function prologue, so if the function has something like > this > if (bug_happened) { > printk("%s: bug happened: %d %d %d %d %d %d %d %d", __func__, a, > b, c, d, e, f, g, h, i); > } > the whole function always wastes 10 stack words, even if the bug doesn't > happen :( > > But that one word because of __func__ maybe doesn't matter (there are much > more wasted already in these printks). Or do you think that it's better to > not do this __func__ conversion? I think the use of __func__ reduces the maintenance cost of keeping the printk updated if the code were to change. Like I said, I found ~3 remaining function name inconsistencies. Plus I had already fixed a few others in my previous large whitespace patch. Anyway, I understand your point on the extra word associated with using __func__ but feel using it is more helpful. Mike -- dm-devel mailing list dm-devel@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/dm-devel