Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




Hi Charles,

On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
<ckeepax@xxxxxxxxxxxxxxxxxxxxxxxxxxx> wrote:
> This patch adds bindings for the basic microphone detection platform
> data.
>
> Signed-off-by: Charles Keepax <ckeepax@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
> ---
>  drivers/extcon/extcon-arizona.c |   29 +++++++++++++++++++++++++++++
>  1 files changed, 29 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/extcon/extcon-arizona.c b/drivers/extcon/extcon-arizona.c
> index 1153929..5bf1b19 100644
> --- a/drivers/extcon/extcon-arizona.c
> +++ b/drivers/extcon/extcon-arizona.c
> @@ -1115,6 +1115,7 @@ static int arizona_extcon_device_get_pdata(struct arizona *arizona)
>  {
>         struct arizona_pdata *pdata = &arizona->pdata;
>         unsigned int val = ARIZONA_ACCDET_MODE_HPL;
> +       unsigned int dbtime;
>
>         device_property_read_u32(arizona->dev, "wlf,hpdet-channel", &val);
>         switch (val) {
> @@ -1128,6 +1129,34 @@ static int arizona_extcon_device_get_pdata(struct arizona *arizona)
>                 pdata->hpdet_channel = ARIZONA_ACCDET_MODE_HPL;
>         }
>
> +       device_property_read_u32(arizona->dev, "wlf,micd-detect-debounce",
> +                                &pdata->micd_detect_debounce);
> +
> +       device_property_read_u32(arizona->dev, "wlf,micd-bias-start-time",
> +                                &pdata->micd_bias_start_time);
> +
> +       device_property_read_u32(arizona->dev, "wlf,micd-rate",
> +                                &pdata->micd_rate);
> +
> +       dbtime = 0;
> +       device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> +       switch (dbtime) {
> +       case 2:

I'd like you to define the constant variable for specific integer
value to improve the readability.
e.g.,

#define MICD_DBTIME_XXX 2
#define MICD_DBTIME_XXX 4

> +               pdata->micd_dbtime = 0x10000;

Also, you better to define the constant variable for "0x10000" to
improbe readability in the include/linux/mfd/arizona.h. If you just
use the hex value, the other developer cannot analyze the meaning of
"0x10000".

> +               break;
> +       case 4:

ditto.

> +               pdata->micd_dbtime = 0x0001;

ditto.

> +               break;
> +       default:
> +               break;
> +       }
> +
> +       device_property_read_u32(arizona->dev, "wlf,micd-timeout",
> +                                &pdata->micd_timeout);
> +
> +       pdata->micd_force_micbias = device_property_read_bool(arizona->dev,
> +                                               "wlf,micd-force-micbias");
> +
>         return 0;
>  }

Thanks,
Chanwoo Choi
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]
  Powered by Linux