Hello Junhao,
On 2025-01-12 23:27, Junhao Xie wrote:
On 2025/1/12 16:50, Dragan Simic wrote:
On 2025-01-12 08:33, Junhao Xie wrote:
Add dts for Ariaboard Photonicat RK3568.
This series bring support for:
* Debug UART
* SDIO QCA9377 WiFi and Bluetooth
* M.2 E-Key PCIe WiFi and Bluetooth
* M.2 B-Key USB Modem WWAN
* Ethernet WAN Port
* MicroSD Card slot
* eMMC
* HDMI Output
* Mali GPU
* USB Type-A
Changed from v1:
- move some general nodes (firmware, ramoops, reboot-mode) to
rk356x.dtsi
This entry from the changelog caught my attention, so I tried
to find out what exactly happened back then. Though, after going
through the mailing list archive, I still don't see where the
as-described change took place, so perhaps this changelog entry
needs adjusting.
Chukun Pan suggested moving these nodes to rk356x.dtsi, but I have
not done that yet and simply deleted them. I will fix the changelog.
https://lore.kernel.org/lkml/20240905034009.28124-1-amadeus@xxxxxxxxxx/
- remove some general nodes (firmware, ramoops, reboot-mode)
Oh, thanks for the nudge, I just added a TODO to "sprinkle" a few
"syscon-reboot-mode" and "ramoops" nodes onto the relevant SoC dtsi
files. Those will be highly useful when debugging mysterious crashes
and lockups that happen on various devices in the field.
- gmac1 change to phy-mode rgmii-id
- corrected some regulator to be closer to schematics
- rename rk3568-ariaboard-photonicat.dts to rk3568-photonicat.dts
https://lore.kernel.org/lkml/20240904111456.87089-1-bigfoot@xxxxxxxxxxx/
Changed from v2:
- remove unused headers
- corrected some regulator to be closer to schematics
- remove usb_host1_ohci, usb_host1_ehci, usb2phy1_host that have no
connection
https://lore.kernel.org/lkml/20240906045706.1004813-1-bigfoot@xxxxxxxxxxx/
Changed from v3:
- corrected some regulator to be closer to schematics
- changed to using clk32k_out1 in xin32k
https://lore.kernel.org/lkml/20240911122809.1789778-2-bigfoot@xxxxxxxxxxx/
Changed from v4:
- corrected some regulator to be closer to schematics
- corrected some label to match node name
- use resets props in phy node instead deprecated snps,reset-gpio
https://lore.kernel.org/lkml/20240914145549.879936-1-bigfoot@xxxxxxxxxxx/
Changed from v5:
- resort regulator nodes
- remove dr_mode from usb_host1_xhci
https://lore.kernel.org/lkml/20241108031847.700606-1-bigfoot@xxxxxxxxxxx/
Junhao Xie (3):
dt-bindings: vendor-prefixes: Add prefix for Ariaboard
dt-bindings: arm: rockchip: Add Ariaboard Photonicat RK3568
arm64: dts: rockchip: add dts for Ariaboard Photonicat RK3568
.../devicetree/bindings/arm/rockchip.yaml | 5 +
.../devicetree/bindings/vendor-prefixes.yaml | 2 +
arch/arm64/boot/dts/rockchip/Makefile | 1 +
.../boot/dts/rockchip/rk3568-photonicat.dts | 599
++++++++++++++++++
4 files changed, 607 insertions(+)
create mode 100644
arch/arm64/boot/dts/rockchip/rk3568-photonicat.dts
Thanks for your review, I will fix all problems in next version!
Thanks, although it was just a "mile-high" review that covered
only a few things that caught my attention. :)