On Mon, 25 Nov 2024 at 09:45, Neil Armstrong <neil.armstrong@xxxxxxxxxx> wrote: > > +static int summit_suspend(struct device *dev) > > +{ > > + struct summit_data *panel = dev_get_drvdata(dev); > > + > > + int err = mipi_dsi_dcs_set_display_brightness(panel->dsi, 0); > > + > > + if (err < 0) > > + return err; > > + return 0; > > Just return err here, add a common function to set a brighness value and > avoid duplicate code like here. I felt that mipi_dsi_dcs_set_display_brightness is common enough, is it not? Ack on all other changes, will be done for v2.