Hi, Julien: On Fri, 2024-11-22 at 10:16 +0100, Julien Stephan wrote: > External email : Please do not click links or open attachments until you have verified the sender or the content. > > > Le ven. 22 nov. 2024 à 08:54, CK Hu (胡俊光) <ck.hu@xxxxxxxxxxxx> a écrit : > > > > Hi, Julien: > > > > On Thu, 2024-11-21 at 09:53 +0100, Julien Stephan wrote: > > > External email : Please do not click links or open attachments until you have verified the sender or the content. > > > > > > > > > From: Phi-bang Nguyen <pnguyen@xxxxxxxxxxxx> > > > > > > This driver provides a path to bypass the SoC ISP so that image data > > > coming from the SENINF can go directly into memory without any image > > > processing. This allows the use of an external ISP. > > > > > > Signed-off-by: Phi-bang Nguyen <pnguyen@xxxxxxxxxxxx> > > > Signed-off-by: Florian Sylvestre <fsylvestre@xxxxxxxxxxxx> > > > [Paul Elder fix irq locking] > > > Signed-off-by: Paul Elder <paul.elder@xxxxxxxxxxxxxxxx> > > > Co-developed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > Co-developed-by: Julien Stephan <jstephan@xxxxxxxxxxxx> > > > Signed-off-by: Julien Stephan <jstephan@xxxxxxxxxxxx> > > > --- > > > > [snip] > > > > > +static void mtk_cam_cmos_vf_enable(struct mtk_cam_dev *cam_dev, > > > + bool enable, bool pak_en) > > > +{ > > > + if (enable) > > > + cam_dev->hw_functions->mtk_cam_cmos_vf_hw_enable(cam_dev); > > > > Directly call mtk_camsv30_cmos_vf_hw_enable(). > > This has discussed in previous version [1]. > > > > [1] https://urldefense.com/v3/__https://patchwork.kernel.org/project/linux-mediatek/patch/20240729-add-mtk-isp-3-0-support-v6-4-c374c9e0c672@xxxxxxxxxxxx/*25966327__;Iw!!CTRNKA9wMg0ARbw!lydgLydtAuzr-BC5qArz3AEzOM0iSSr6TXifwab1kPvWVJLy0k7rUiasR_goMAF_6XYmPIpErGF6CdLkPQ$ > > > > Hi CK, > > I forgot about that discussion sorry :/ > I guess you want me to completely remove the mtk_cam_hw_functions struct? > In that case, what do you prefer: > - keep mtk_camsv30_hw.c and put signatures in mtkcamsv30_hw.h and > include mtk_camsv30_hw.h in mtk_camsv_video.c > - rename mtk_camsv30_hw.c to mtk_camsv_hw.c (and all functions) and > put signatures in mtk_camsv_hw.h I prefer the second one. Regards, CK > > Cheers > Julien > > > Regards, > > CK > > > > > + else > > > + cam_dev->hw_functions->mtk_cam_cmos_vf_hw_disable(cam_dev); > > > +} > > > + > > > > > > > ************* MEDIATEK Confidentiality Notice ******************** > > The information contained in this e-mail message (including any > > attachments) may be confidential, proprietary, privileged, or otherwise > > exempt from disclosure under applicable laws. It is intended to be > > conveyed only to the designated recipient(s). Any use, dissemination, > > distribution, printing, retaining or copying of this e-mail (including its > > attachments) by unintended recipient(s) is strictly prohibited and may > > be unlawful. If you are not an intended recipient of this e-mail, or believe > > that you have received this e-mail in error, please notify the sender > > immediately (by replying to this e-mail), delete any and all copies of > > this e-mail (including any attachments) from your system, and do not > > disclose the content of this e-mail to any other person. Thank you!