Hello, On Tue, Oct 15, 2024 at 01:51:31PM +0300, Ciprian Costea wrote: > +static void rtc_disable(struct rtc_priv *priv) A very generic name for a driver specific function. I'm a big fan of driver specific prefixes and I wonder why this isn't called s34g_rtc_disable(). Also a comment about what is actually disabled here would be nice (or maybe a better name). I hope this doesn't stop the RTC ticking?? > +static struct platform_driver rtc_driver = { > + .driver = { > + .name = "s32g-rtc", > + .pm = &rtc_pm_ops, > + .of_match_table = rtc_dt_ids, > + }, > + .probe = rtc_probe, > + .remove_new = rtc_remove, > +}; After commit 0edb555a65d1 ("platform: Make platform_driver::remove() return void") .remove() is (again) the right callback to implement for platform drivers. Please just drop "_new". Best regards Uwe
Attachment:
signature.asc
Description: PGP signature