On Thursday 05 March 2015 09:06:54 Geert Uytterhoeven wrote: > On Wed, Mar 4, 2015 at 8:49 PM, Arnd Bergmann <arnd@xxxxxxxx> wrote: > > --- a/drivers/of/unittest.c > > +++ b/drivers/of/unittest.c > > @@ -979,7 +979,7 @@ static int of_path_platform_device_exists(const char *path) > > return pdev != NULL; > > } > > > > -#if IS_ENABLED(CONFIG_I2C) > > +#if IS_BUILTIN(CONFIG_I2C) > > Wondering: is there any advantage in using "#if IS_BUILTIN(CONFIG_XXX)" > instead of "#ifdef CONFIG_XXX"? Mostly consistency within the file. There are also lines like #if IS_BUILTIN(CONFIG_I2C) && IS_ENABLED(CONFIG_OF_OVERLAY) which I find more readable than mixing the two styles as in #if defined(CONFIG_I2C) && IS_ENABLED(CONFIG_OF_OVERLAY) Arnd -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html