On Thu, Jun 27, 2024 at 02:57:48PM +0800, Shawn Guo wrote: > On Mon, Jun 17, 2024 at 09:18:42AM +0200, Francesco Dolcini wrote: > > Hello Shawn, > > > > On Mon, Jun 17, 2024 at 10:33:50AM +0800, Shawn Guo wrote: > > > On Thu, Jun 13, 2024 at 02:41:50PM +0100, Vitor Soares wrote: > > > > From: Vitor Soares <vitor.soares@xxxxxxxxxxx> > > > > > > > > Add TPM device found on Verdin iMX8M Mini PID4 0090 variant. > > > > > > > > Signed-off-by: Vitor Soares <vitor.soares@xxxxxxxxxxx> > > > > --- > > > > arch/arm64/boot/dts/freescale/imx8mm-verdin.dtsi | 16 +++++++++++----- > > > > 1 file changed, 11 insertions(+), 5 deletions(-) > > > > > > > > diff --git a/arch/arm64/boot/dts/freescale/imx8mm-verdin.dtsi b/arch/arm64/boot/dts/freescale/imx8mm-verdin.dtsi > > > > index 4768b05fd765..c9ae5f0bb526 100644 > > > > --- a/arch/arm64/boot/dts/freescale/imx8mm-verdin.dtsi > > > > +++ b/arch/arm64/boot/dts/freescale/imx8mm-verdin.dtsi > > > > @@ -227,15 +227,16 @@ &ecspi2 { > > > > pinctrl-0 = <&pinctrl_ecspi2>; > > > > }; > > > > > > > > -/* Verdin CAN_1 (On-module) */ > > > > +/* On-module SPI */ > > > > &ecspi3 { > > > > #address-cells = <1>; > > > > #size-cells = <0>; > > > > - cs-gpios = <&gpio5 25 GPIO_ACTIVE_LOW>; > > > > + cs-gpios = <&gpio5 25 GPIO_ACTIVE_LOW>, <&gpio4 19 GPIO_ACTIVE_LOW>; > > > > pinctrl-names = "default"; > > > > - pinctrl-0 = <&pinctrl_ecspi3>; > > > > + pinctrl-0 = <&pinctrl_ecspi3>, <&pinctrl_pmic_tpm_ena>; > > > > > > Would it make more sense to have tpm pinctrl in node tpm@1 below? > > It's the pinctrl of the SPI Chip Select pin, not something about the > > TPM, I think it's correct to have it into the ecspi node. > > The name pinctrl_pmic_tpm_ena seems confusing then. I agree (this is coming from the schematics net name, let's blame the HW folks). With that said, let's rename this to `pinctrl_tpm_spi_cs`. Vitor? Francesco