On Thu, 18 Apr 2024 at 14:31, Konrad Dybcio <konrad.dybcio@xxxxxxxxxx> wrote: > > On 18.04.2024 1:07 PM, Dmitry Baryshkov wrote: > > On Thu, Apr 18, 2024 at 11:51:16AM +0200, Konrad Dybcio wrote: > >> On 18.04.2024 1:43 AM, Dmitry Baryshkov wrote: > >>> On Wed, Apr 17, 2024 at 10:02:55PM +0200, Konrad Dybcio wrote: > >>>> On recent (SM8550+) Snapdragon platforms, the GPU speed bin data is > >>>> abstracted through SMEM, instead of being directly available in a fuse. > >>>> > >>>> Add support for SMEM-based speed binning, which includes getting > >>>> "feature code" and "product code" from said source and parsing them > >>>> to form something that lets us match OPPs against. > >>>> > >>>> Due to the product code being ignored in the context of Adreno on > >>>> production parts (as of SM8650), hardcode it to SOCINFO_PC_UNKNOWN. > >>>> > >>>> Signed-off-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxx> > >>>> --- > >> > >> [...] > >> > >>>> --- a/drivers/gpu/drm/msm/adreno/adreno_device.c > >>>> +++ b/drivers/gpu/drm/msm/adreno/adreno_device.c > >>>> @@ -6,6 +6,8 @@ > >>>> * Copyright (c) 2014,2017 The Linux Foundation. All rights reserved. > >>>> */ > >>>> > >>>> +#include <linux/soc/qcom/socinfo.h> > >>>> + > >>> > >>> Stray leftover? > >> > >> Looks like > >> > >> [...] > >> > >>>> + > >>>> +#ifdef CONFIG_QCOM_SMEM > >>> > >>> Please extract to a separate function and put the function under ifdef > >>> (providing a stub otherwise). Having #ifndefs inside funciton body is > >>> frowned upon. > >> > >> Hm, this looked quite sparse and straightforward, but I can do that. > >> > >> [...] > >> > >>>> +/* As of SM8650, PCODE on production SoCs is meaningless wrt the GPU bin */ > >>>> +#define ADRENO_SKU_ID_FCODE GENMASK(15, 0) > >>>> +#define ADRENO_SKU_ID(fcode) (SOCINFO_PC_UNKNOWN << 16 | fcode) > >>> > >>> If we got rid of PCode matching, is there a need to actually use > >>> SOCINFO_PC_UNKNOWN here? Or just 0 would be fine? > >> > >> The IDs need to stay constant for mesa > >> > >> I used the define here to: > >> > >> a) define the SKU_ID structure so that it's clear what it's comprised of > >> b) make it easy to add back Pcode in case it becomes useful with future SoCs > >> c) avoid mistakes - PC_UNKNOWN happens to be zero, but that's a lucky > >> coincidence > >> > >> We don't *match* based on PCODE, but still need to construct the ID properly > >> > >> Another option would be to pass the real pcode and add some sort of > >> "pcode_invalid" property that if found would ignore this part of the > >> SKU_ID in mesa, but that sounds overly and unnecessarily complex. > > > > It's fine, just add a comment please. Maybe we can rename PC_UNKNOWN to > > PC_PRODUCTION? > > I don't think that's right. The SoC "product code" may actually mean something > (again, not necessarily for Adreno specifically), and with Adreno in mind, it > being only meaningful for engineering samples may change in the future. Ack -- With best wishes Dmitry