Hello Andrew, hello Nishanth On Wed, Aug 02, 2023 at 12:45:21PM -0500, Andrew Davis wrote: > The name "clock" is not allowed for nodes, use "clock-controller" to > remove the DTS check warning. > > Signed-off-by: Andrew Davis <afd@xxxxxx> > --- > arch/arm64/boot/dts/ti/k3-am64-main.dtsi | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm64/boot/dts/ti/k3-am64-main.dtsi b/arch/arm64/boot/dts/ti/k3-am64-main.dtsi > index e27eb2e585f14..4e3e450e4e4c8 100644 > --- a/arch/arm64/boot/dts/ti/k3-am64-main.dtsi > +++ b/arch/arm64/boot/dts/ti/k3-am64-main.dtsi > @@ -61,7 +61,7 @@ phy_gmii_sel: phy@4044 { > #phy-cells = <1>; > }; > > - epwm_tbclk: clock@4140 { > + epwm_tbclk: clock-controller@4140 { I was asked to do the exact same change here [1] by Nishanth, and I'm sending the updated patch in a short while. However I have one question, according to the devicetree-specification-v0.4.pdf [2] "2.2.2 Generic Names Recommendation", clock is a valid node name. While testing the DT (make CHECK_DTBS=y), I did not have any warning nor error. What am I missing? In addition to that I guess we should also update the example in the dt bindings yaml file. Francesco [1] https://lore.kernel.org/all/20230731142135.108477-2-francesco@xxxxxxxxxx/ [2] https://github.com/devicetree-org/devicetree-specification/releases/download/v0.4/devicetree-specification-v0.4.pdf