Hello Serge, > From: Serge Semin, Sent: Monday, June 5, 2023 8:08 AM > > On Wed, May 10, 2023 at 03:22:15PM +0900, Yoshihiro Shimoda wrote: > > Add "Message Routing" and "INTx Mechanism Messages" macros to send > > a message by a PCIe driver. > > > > Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@xxxxxxxxxxx> > > --- > > drivers/pci/pci.h | 18 ++++++++++++++++++ > > 1 file changed, 18 insertions(+) > > > > diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h > > index 2475098f6518..67badc40e90b 100644 > > --- a/drivers/pci/pci.h > > +++ b/drivers/pci/pci.h > > @@ -11,6 +11,24 @@ > > > > #define PCI_VSEC_ID_INTEL_TBT 0x1234 /* Thunderbolt */ > > > > > +/* Message Routing */ > > Call it "Implicit Message Routing (r[2:0])" as per the specification. I got it. > > +#define PCI_MSG_ROUTING_RC 0 > > +#define PCI_MSG_ROUTING_ADDR 1 > > +#define PCI_MSG_ROUTING_ID 2 > > +#define PCI_MSG_ROUTING_BC 3 > > +#define PCI_MSG_ROUTING_LOCAL 4 > > +#define PCI_MSG_ROUTING_GATHER 5 > > IMO prefix like this PCI_MSG_TYPE_R_{RC,ADDR,ID,BC,...} would be a bit > better since it would indicate that this routing flags are a sub-field of > the Message Type field. Bjorn? I got it. I'll rename them. > > + > > +/* INTx Mechanism Messages */ > > +#define PCI_CODE_ASSERT_INTA 0x20 > > +#define PCI_CODE_ASSERT_INTB 0x21 > > +#define PCI_CODE_ASSERT_INTC 0x22 > > +#define PCI_CODE_ASSERT_INTD 0x23 > > +#define PCI_CODE_DEASSERT_INTA 0x24 > > +#define PCI_CODE_DEASSERT_INTB 0x25 > > +#define PCI_CODE_DEASSERT_INTC 0x26 > > +#define PCI_CODE_DEASSERT_INTD 0x27 > > IMO Prefix PCI_MSG_CODE_... would be a bit more descriptive since per > the specification the respective message field is called "Message > Code" and not just "Code". Bjorn? I got it. I'll rename them. Best regards, Yoshihiro Shimoda > -Serge(y) > > > + > > extern const unsigned char pcie_link_speed[]; > > extern bool pci_early_dump; > > > > -- > > 2.25.1 > >