Several weeks ago, I sent a series [1] for adding a potentiometer as an auxiliary device in ASoC. The feedback was that the potentiometer should be directly handled in IIO (as other potentiometers) and something more generic should be present in ASoC in order to have a binding to import some IIO devices into sound cards. The series related to the IIO potentiometer device is already under review [2]. This series introduces audio-iio-aux. Its goal is to offer the binding between IIO and ASoC. It exposes attached IIO devices as ASoC auxiliary devices and allows to control them through mixer controls. On my system, the IIO device is a potentiometer and it is present in an amplifier design present in the audio path. Compare to the previous iteration https://lore.kernel.org/linux-kernel/20230421124122.324820-1-herve.codina@xxxxxxxxxxx/ This v2 series mainly: - updates the binding using a simple-card subnode and handles this new subnode in the simple-card driver. - Improves existing IIO code and documentation. - Renames simple-iio-aux to audio-iio-aux and fixes the driver itself. Best regards, Hervé [1] https://lore.kernel.org/linux-kernel/20230203111422.142479-1-herve.codina@xxxxxxxxxxx/ [2] https://lore.kernel.org/linux-kernel/20230421085245.302169-1-herve.codina@xxxxxxxxxxx/ Changes v1 -> v2 - Patch 1 Rename simple-iio-aux to audio-iio-aux Rename invert to snd-control-invert-range Remove the /schemas/iio/iio-consumer.yaml reference Remove the unneeded '|' after description - Patch 2 (new in v2) Introduce the simple-audio-card additional-devs subnode - Patch 3 (new in v2) Check err before switch() in iio_channel_read_max() - Patch 4 (new in v2) Fix raw reads and raw writes documentation - Patch 5 (patch 2 in v1) Check err before switch() in iio_channel_read_min() Fix documentation - Patch 6 (path 3 in v1) No changes - Patch 7 (patch 4 in v1) Rename simple-iio-aux to audio-iio-aux Rename invert to snd-control-invert-range Remove the mask usage from audio_iio_aux_{get,put}_volsw helpers Use directly PTR_ERR() in dev_err_probe() parameter Remove the '!!' construction Remove of_match_ptr() - Patch 8 (new in v2) Add a missing of_node_put() in the simple-card driver - Patch 9 (new in v2) Handle additional-devs in the simple-card driver Herve Codina (9): ASoC: dt-bindings: Add audio-iio-aux ASoC: dt-bindings: simple-card: Add additional-devs subnode iio: inkern: Check error explicitly in iio_channel_read_max() iio: consumer.h: Fix raw values documentation notes iio: inkern: Add a helper to query an available minimum raw value ASoC: soc-dapm.h: Add a helper to build a DAPM widget dynamically ASoC: codecs: Add support for the generic IIO auxiliary devices ASoC: simple-card: Add missing of_node_put() in case of error ASoC: simple-card: Handle additional devices .../bindings/sound/audio-iio-aux.yaml | 64 ++++ .../bindings/sound/simple-card.yaml | 53 +++ drivers/iio/inkern.c | 75 ++++- include/linux/iio/consumer.h | 37 ++- include/sound/soc-dapm.h | 12 +- sound/soc/codecs/Kconfig | 12 + sound/soc/codecs/Makefile | 2 + sound/soc/codecs/audio-iio-aux.c | 302 ++++++++++++++++++ sound/soc/generic/simple-card.c | 53 ++- 9 files changed, 596 insertions(+), 14 deletions(-) create mode 100644 Documentation/devicetree/bindings/sound/audio-iio-aux.yaml create mode 100644 sound/soc/codecs/audio-iio-aux.c -- 2.40.1