To support ufs #1 for Exynos Auto v9 SoC, we need to control its own pmu register. So, we need to specify the offset of the register via an argument of syscon node. Changes from v2: - Exclude dts patchset because they'll be queued by Krzysztof after v5.19 merge window. - 0001-dt-bindings: Add "maxItems: 1" to the first level pmu-syscon items as suggested by Krzysztof - 0002: The patch has been added to clarify the variable name - 0004: The patch has been added to remove drvdata pointer as suggested by Krzysztof Changes from v1: - dt-bindings: Correct tab align and add "minItems: 1" to make the second cell as optional. - Add 0001- patch to constify phy_cfg. - Allocate phy->isol and copy data from drvdata to avoid const qualifier error - Add 0004- patch to apply dt style for ufs0 as Krzysztof's suggestion - Align tab and apply ufs node naming for device tree nodes Chanho Park (5): dt-bindings: phy: samsung,ufs-phy: make pmu-syscon as phandle-array phy: samsung: ufs: rename cfg to cfgs for clarification phy: samsung: ufs: constify samsung_ufs_phy_cfg phy: samsung: ufs: remove drvdata from struct samsung_ufs_phy phy: samsung: ufs: support secondary ufs phy .../bindings/phy/samsung,ufs-phy.yaml | 14 ++++++++--- drivers/phy/samsung/phy-exynos7-ufs.c | 2 +- drivers/phy/samsung/phy-exynosautov9-ufs.c | 2 +- drivers/phy/samsung/phy-samsung-ufs.c | 18 +++++++++----- drivers/phy/samsung/phy-samsung-ufs.h | 24 ++++++++++--------- 5 files changed, 38 insertions(+), 22 deletions(-) -- 2.36.1