On Thu, Apr 14, 2022 at 10:19 AM xiazhengqiao <xiazhengqiao@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> wrote: > Add dt-bindings for 10.1" TFT LCD module called STARRY 2081101 > QFH032011-53G. > > Signed-off-by: xiazhengqiao <xiazhengqiao@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> > Reviewed-by: Rob Herring <robh@xxxxxxxxxx> (...) > + enable-gpios: > + description: a GPIO spec for the enable pin The way this is used in the code makes me suspect this should be named reset-gpios. What is the name of the pin on the panel? It also appears you should tag this as active low so in that case write that in the description "always tag with GPIO_ACTIVE_LOW" (and alter the code in the driver to match the inversion) > + pp1800-supply: > + description: core voltage supply Hm the name of this supply makes me think the display controller is actually named pp1800. Is this correct? > + enable-gpios = <&pio 45 0>; Don't use ordinal flags in examples. examples: - | #include <dt-bindings/gpio/gpio.h> (...) reset-gpios = <&gpio4 11 GPIO_ACTIVE_LOW>; Yours, Linus Walleij