Hi, On Wed, Mar 16, 2022 at 10:36 AM Sankeerth Billakanti <quic_sbillaka@xxxxxxxxxxx> wrote: > > Enable support for eDP interface via aux_bus on CRD platform. > > Signed-off-by: Sankeerth Billakanti <quic_sbillaka@xxxxxxxxxxx> > --- > > Changes in v5: > - Change the order of patches > - Remove the backlight nodes > - Remove the bias setting > - Fix compilation issue > - Model VREG_EDP_BP for backlight power > > Changes in v4: > - Create new patch for name changes > - Remove output-low > > Changes in v3: > - Sort the nodes alphabetically > - Use - instead of _ as node names > - Place the backlight and panel nodes under root > - Change the name of edp_out to mdss_edp_out > - Change the names of regulator nodes > - Delete unused properties in the board file > > > Changes in v2: > - Sort node references alphabetically > - Improve readability > - Move the pwm pinctrl to pwm node > - Move the regulators to root > - Define backlight power > - Remove dummy regulator node > - Cleanup pinctrl definitions > > arch/arm64/boot/dts/qcom/sc7280-crd.dts | 93 +++++++++++++++++++++++++++++++++ > 1 file changed, 93 insertions(+) At a high level, I'd expect your patch to be based upon Matthias's series, AKA the 4 patches from: https://lore.kernel.org/r/20220316172814.v1.1.I2deda8f2cd6adfbb525a97d8fee008a8477b7b0e@changeid/ I'll leave it up to you about whether you care to support eDP on the old CRD1/2 or just on CRD3. Personally I'd think CRD3 would be enough. Then, I'd expect your patch to mostly incorporate <https://crrev.com/c/3379844>, though that patch was written before aux-bus support so the panel would need to go in a different place. Stephen already gave some comments and basing on Matthias's patches will be a pretty big change, so I probably won't comment lots more. > +&mdss_edp { > + status = "okay"; > + > + data-lanes = <0 1 2 3>; > + vdda-1p2-supply = <&vreg_l6b_1p2>; > + vdda-0p9-supply = <&vreg_l10c_0p8>; > + > + aux-bus { > + edp_panel: edp-panel { As Stephen pointed out, it should be called "panel".