On Fri, Feb 11, 2022 at 06:38:08PM +0800, Jiaxin Yu wrote: Again, mostly looks good just some minor issues (I've not repeated some that applied to the prior code): > +static const struct snd_kcontrol_new mtk_hw_gain2_in_ch1_mix[] = { > + SOC_DAPM_SINGLE_AUTODISABLE("ADDA_UL_CH1", AFE_CONN15, > + I_ADDA_UL_CH1, 1, 0), > +}; These end up as regular user visible controls so should have standard control names - in this case ending in Switch since it's a simple on/off. A similar issue was there in the earlier patches. > +static const struct snd_kcontrol_new mtk_hw_gain_controls[] = { > + SOC_SINGLE("HW Gain 1", AFE_GAIN1_CON1, > + GAIN1_TARGET_SFT, GAIN1_TARGET_MASK, 0), > + SOC_SINGLE("HW Gain 2", AFE_GAIN2_CON1, > + GAIN2_TARGET_SFT, GAIN2_TARGET_MASK, 0), These should have standard names like "HW 1 Volume" so userspace has a better idea how to display them.
Attachment:
signature.asc
Description: PGP signature