Hello, Here's v10. Not much different from v9. The code and the generic bindings looked good enough to relevant gods, but the patchset still needs some formal loving in the form of Acked-by's. Changes since v9: o Purely cosmetic changes - added headers and used BIT() Changes since v8: o Nits like spelling corrections and a couple symbol renames o Made 'mbox-names' optional in favor of index of mailbox specifier in 'mboxes' property. Which results in mbox_request_channel(struct mbox_client *cl) to mbox_request_channel(struct mbox_client *cl, int index) o Separate out Documentation and Bindings patches. Changes since v7: o Added documentation and example usage. o Merged all patches into one that create api, bindings and documentation. Changes since v6: o Separate out generic DT bindings patch. o Discard unnecessary aligned attributes. Changes since v5: o Use standard error types instead of special type mbox_result. o Constify client struct in request_channel o Use reinit_completion instead of init_completion every time. o Improve commentary in bindings and code. Changes since v4: o Common DT binding for Controller and Client drivers As a result, discard string based channel matching o Provide for an atomic 'peek' api, that a client could call to trigger the controller driver push data upwards. o OMAP and Highbank conversion to new api is left out, which can be converted later by the developers. Changes since v3: o Change name of symbols from ipc to mbox o Return real types instead of void * o Align structures o Change some symbol names rxcb -> rx_callback txcb -> tx_done o Added kernel-doc for exported API o Dropped the cl_id and use clients pointer for callbacks. o Fixed locking of channel pool o Return negative error code for unsuccessful ipc_send_message() o Module referencing during mailbox assignment to a client. o Made error code symbols specific to mailbox. Thanks -Jassi Jassi Brar (3): mailbox: Introduce framework for mailbox doc: add documentation for mailbox framework dt: mailbox: add generic bindings Suman Anna (1): mailbox: rename pl320-ipc specific mailbox.h .../devicetree/bindings/mailbox/mailbox.txt | 36 ++ Documentation/mailbox.txt | 122 ++++++ MAINTAINERS | 8 + arch/arm/mach-highbank/highbank.c | 2 +- drivers/cpufreq/highbank-cpufreq.c | 2 +- drivers/mailbox/Makefile | 4 + drivers/mailbox/mailbox.c | 466 +++++++++++++++++++++ drivers/mailbox/pl320-ipc.c | 2 +- include/linux/mailbox_client.h | 46 ++ include/linux/mailbox_controller.h | 135 ++++++ include/linux/{mailbox.h => pl320-ipc.h} | 0 11 files changed, 820 insertions(+), 3 deletions(-) create mode 100644 Documentation/devicetree/bindings/mailbox/mailbox.txt create mode 100644 Documentation/mailbox.txt create mode 100644 drivers/mailbox/mailbox.c create mode 100644 include/linux/mailbox_client.h create mode 100644 include/linux/mailbox_controller.h rename include/linux/{mailbox.h => pl320-ipc.h} (100%) -- 1.8.1.2 -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html