> > > > Hi Lee > > > > The PHC driver already existed in the current tree as > > drivers/ptp/ptp_clockmatrix.c and ptp_idt82p33.c > > > > Right now, they act as i2c driver. I plan to change them as a normal > > platform device driver after this MFD change kicked in > > > > That is why I would prefer the name "phc" instead of "clock" since the > > driver is not a normal clk driver under drivers/clk but a ptp clock > > driver. And down the road, we will have our real clock driver and I wanna > reserve the name "clock" for the real clock driver. > > I see. To be honest, I wasn't aware of the PTP subsystem. > > In which case, the name needs to match the one in the driver: > > static struct i2c_driver idtcm_driver = { > .driver = { > .of_match_table = of_match_ptr(idtcm_dt_id), > .name = "idtcm", > }, > .probe = idtcm_probe, > .remove = idtcm_remove, > .id_table = idtcm_i2c_id, > }; > > So, "idtcm" in this case. > > How else will it match? > Hi Lee I actually like to comply with the mfd sub device naming convention by naming it 8a3400x-phc About the names in ptp clock driver, I will have to change them anyways down the road to make them work with the mfd driver Another match doesn't exist in the current tree yet. It would be a normal platform device driver that I will submit to drivers/misc a little later after this mfd change is merged. Thanks Min