Re: [PATCH mfd v2] mfd: Add Renesas Synchronization Management Unit (SMU) support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 16 Jun 2021, Min Li wrote:

> > 
> > > >
> > > > > +static struct mfd_cell rsmu_cm_devs[] = {
> > > > > +	[RSMU_PHC] = {
> > > > > +		.name = "idtcm-phc",
> > > >
> > > > Can't you have a nicer name?
> > > >
> > > Hi Lee
> > >
> > > I wonder which part of the name that you don't like? PHC stands from PTP
> > Hardware Clock.
> > > I was following the name convention like tps65912-regulator.
> > > Do you accept "8a3400-phc"?
> > 
> > I think you're trying to put too much information into the device name.
> > 
> > Currently it's:
> > 
> >   idt <company name> cm <platform> - phc <exact device type>
> > 
> > Where usually we have, taking your example:
> > 
> >   tps65912 <chip> - regulator <subsystem>
> > 
> > So assuming the PTP HW Clock is just a clock it should be:
> > 
> >   8a3400 <chip> - clock <subsystem>
> > 
> > It's difficult to say without seeing the associated child device(s).
> > When do you propose to upstream those?  Maybe they should be part of
> > this initial set.  I think that would help a lot.
> > 
> 
> Hi Lee
> 
> The PHC driver already existed in the current tree as drivers/ptp/ptp_clockmatrix.c and
> ptp_idt82p33.c
> 
> Right now, they act as i2c driver. I plan to change them as a normal platform device driver
> after this MFD change kicked in
> 
> That is why I would prefer the name "phc" instead of "clock" since the driver is not a normal clk driver
> under drivers/clk but a ptp clock driver. And down the road, we will have our real clock driver and I wanna
> reserve the name "clock" for the real clock driver.

I see.  To be honest, I wasn't aware of the PTP subsystem.

In which case, the name needs to match the one in the driver:

 static struct i2c_driver idtcm_driver = {
        .driver = {
                .of_match_table = of_match_ptr(idtcm_dt_id),
                .name           = "idtcm",
        },
        .probe          = idtcm_probe,
        .remove         = idtcm_remove,
        .id_table       = idtcm_i2c_id,
 };

So, "idtcm" in this case.

How else will it match?

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux