On Mon, Nov 09, 2020 at 07:31:10PM -0800, Florian Fainelli wrote: > The register name should be "sgmii_config", not "sgmii", this is not a > functional change since no code is currently looking for that register > by name (or at all). > > Signed-off-by: Florian Fainelli <f.fainelli@xxxxxxxxx> > --- I.e. no one calls devm_platform_ioremap_resource(pdev, 2), and even if it did, the register name wouldn't matter. ...but at least it's documented that it should be called "sgmii_config". And the address is the same as the one that's documented for the SGMII register base in SoCs with "brcm,nsp-srab", so even without documentation, it is pretty clear to me that it was a mistake calling it simply "sgmii". And if that address is incorrect anyways, at least that would be a separate issue. Reviewed-by: Vladimir Oltean <olteanv@xxxxxxxxx> > arch/arm/boot/dts/bcm-nsp.dtsi | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm/boot/dts/bcm-nsp.dtsi b/arch/arm/boot/dts/bcm-nsp.dtsi > index e7d08959d5fe..09fd7e55c069 100644 > --- a/arch/arm/boot/dts/bcm-nsp.dtsi > +++ b/arch/arm/boot/dts/bcm-nsp.dtsi > @@ -390,7 +390,7 @@ srab: ethernet-switch@36000 { > reg = <0x36000 0x1000>, > <0x3f308 0x8>, > <0x3f410 0xc>; > - reg-names = "srab", "mux_config", "sgmii"; > + reg-names = "srab", "mux_config", "sgmii_config"; > interrupts = <GIC_SPI 95 IRQ_TYPE_LEVEL_HIGH>, > <GIC_SPI 96 IRQ_TYPE_LEVEL_HIGH>, > <GIC_SPI 97 IRQ_TYPE_LEVEL_HIGH>, > -- > 2.25.1 >