On Mon, 2020-09-14 at 22:00 +0800, Crystal Guo wrote: > On Fri, 2020-09-11 at 22:44 +0800, Suman Anna wrote: > > On 9/11/20 9:26 AM, Philipp Zabel wrote: > > > Hi Crystal, > > > > > > On Fri, 2020-09-11 at 14:07 +0800, Crystal Guo wrote: > > > [...] > > >> Should I add the SoC-specific data as follows? > > >> This may also modify the ti original code, is it OK? > > >> > > >> + data->reset_data = of_device_get_match_data(&pdev->dev); > > >> + > > >> + list = of_get_property(np, data->reset_data->reset_bits, &size); > > >> > > >> +static const struct common_reset_data ti_reset_data = { > > >> + .reset_op_available = false, > > >> + .reset_bits = "ti, reset-bits", > > > ^ > > > That space doesn't belong there. > > > > > >> +}; > > >> + > > >> +static const struct common_reset_data mediatek_reset_data = { > > >> + .reset_op_available = true, > > >> + .reset_bits = "mediatek, reset-bits", > > >> +}; > > > > > > I understand Robs comments as meaning "ti,reset-bits" should have been > > > called "reset-bits" in the first place, and you shouldn't repeat adding > > > the vendor prefix, as that is implied by the compatible. So this should > > > probably be just "reset-bits". > > > > Hmm, not sure about that. I think Rob wants the reset data itself to be added in > > the driver as is being done on some other SoCs (eg: like in reset-qcom-pdc.c). > > > > regards > > Suman > > > Hi Rob, > > Can you help to comment about this point? > Modify "ti,reset-bits" to "reset-bits" or add "mediatek,reset-bits" ? > > Many thanks~ > Crystal > > > > > > > Otherwise this looks like it should work. > > > > > > regards > > > Philipp > > > > > Dears, I have uploaded the changes at https://patchwork.kernel.org/cover/11805937/ Please help me to review, many thanks~~ regards Crystal >