On Thu 20 Aug 07:47 UTC 2020, Wesley Cheng wrote: > > > On 8/12/2020 2:34 AM, Sergei Shtylyov wrote: > > Hello! > > > > On 12.08.2020 10:19, Wesley Cheng wrote: > > > >> Add the required DTS node for the USB VBUS output regulator, which is > >> available on PM8150B. This will provide the VBUS source to connected > >> peripherals. > >> > >> Signed-off-by: Wesley Cheng <wcheng@xxxxxxxxxxxxxx> > >> --- > >> arch/arm64/boot/dts/qcom/pm8150b.dtsi | 6 ++++++ > >> arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++ > >> 2 files changed, 10 insertions(+) > >> > >> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi > >> b/arch/arm64/boot/dts/qcom/pm8150b.dtsi > >> index 053c659734a7..9e560c1ca30d 100644 > >> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi > >> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi > >> @@ -53,6 +53,12 @@ power-on@800 { > >> status = "disabled"; > >> }; > >> + pm8150b_vbus: dcdc@1100 { > > > > s/dcdc/regulator/? What is "dcdc", anyway? > > The device nodes must have the generic names, according to the DT spec. > > > > Hi Sergei, > > Thanks for the comment! > > DCDC is the label that we use for the DC to DC converter block, since > the VBUS booster will output 5V to the connected devices. Would it make > more sense to have "dc-dc?" > At this level it's just a regulator at 0x1100, so it should be "regulator@1100". If you would like a more useful name in the running system you should be able to use the "regulator-name" property. Regards, Bjorn > Thanks > Wesley > > >> + compatible = "qcom,pm8150b-vbus-reg"; > >> + status = "disabled"; > >> + reg = <0x1100>; > >> + }; > >> + > >> pm8150b_typec: typec@1500 { > >> compatible = "qcom,pm8150b-usb-typec"; > >> status = "disabled"; > > [...] > > > > MBR, Sergei > > -- > The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, > a Linux Foundation Collaborative Project