Hi Sudeep, Thanks for the review. On Mon, Aug 10, 2020 at 03:41:48PM +0100, Sudeep Holla wrote: > On Mon, Aug 10, 2020 at 05:27:42PM +0300, Sakari Ailus wrote: > > Enable drivers to tell ACPI that there's no need to power on a device for > > probe. Drivers should still perform this by themselves if there's a need > > to. In some cases powering on the device during probe is undesirable, and > > this change enables a driver to choose what fits best for it. > > > > Add a field called "flags" into struct i2c_driver for driver flags, and a > > flag I2C_DRV_FL_ALLOW_LOW_POWER_PROBE to tell a driver supports probe in > > low power state. > > > > Signed-off-by: Sakari Ailus <sakari.ailus@xxxxxxxxxxxxxxx> > > --- > > drivers/i2c/i2c-core-base.c | 17 ++++++++++++++--- > > include/linux/i2c.h | 14 ++++++++++++++ > > 2 files changed, 28 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/i2c/i2c-core-base.c b/drivers/i2c/i2c-core-base.c > > index 34a9609f256da..cde9cf49a07e6 100644 > > --- a/drivers/i2c/i2c-core-base.c > > +++ b/drivers/i2c/i2c-core-base.c > > @@ -436,6 +436,14 @@ static int i2c_smbus_host_notify_to_irq(const struct i2c_client *client) > > return irq > 0 ? irq : -ENXIO; > > } > > > > +static bool allow_low_power_probe(struct device *dev) > > +{ > > + struct i2c_driver *driver = to_i2c_driver(dev->driver); > > + > > + return driver->flags & I2C_DRV_FL_ALLOW_LOW_POWER_PROBE && > > + device_property_present(dev, "allow-low-power-probe"); > > I assume this change makes even the DT property "allow-low-power-probe" > work in the same way. Should we have proper DT binding for that ? > > This comment applies for any property using device_property_* but has > no explicit DT binding ? Just asking the question to know the strategy > followed. Sorry if this is redundant question, feel free to point me > to the past discussions. It's not a redundant question, no. I²C drivers on OF are responsible for controlling device's power state already (using runtime PM or without) so I think the drivers could use the property directly on OF systems (and document the property in DT bindings first) if there's a need to. IOW this code isn't needed on OF. Note that the power_on or power_off arguments are not used by genpd_dev_pm_attach() or genpd_dev_pm_detach() so this patch only affects ACPI. I think I should check the device is an ACPI device above, for clarity. Cc also DT list. The entire set is here: <URL:https://lore.kernel.org/linux-acpi/20200810142747.12400-1-sakari.ailus@xxxxxxxxxxxxxxx/> -- Kind regards, Sakari Ailus