On Thu, 18 Jun 2020, Frank Rowand wrote: > On 2020-06-15 04:26, Lee Jones wrote: > > On Sun, 14 Jun 2020, Frank Rowand wrote: > > > >> Hi Lee, > >> > >> I'm looking at 5.8-rc1. > >> > >> The only use of OF_MFD_CELL() where the same compatible is specified > >> for multiple elements of a struct mfd_cell array is for compatible > >> "stericsson,ab8500-pwm" in drivers/mfd/ab8500-core.c: > >> > >> OF_MFD_CELL("ab8500-pwm", > >> NULL, NULL, 0, 1, "stericsson,ab8500-pwm"), > >> OF_MFD_CELL("ab8500-pwm", > >> NULL, NULL, 0, 2, "stericsson,ab8500-pwm"), > >> OF_MFD_CELL("ab8500-pwm", > >> NULL, NULL, 0, 3, "stericsson,ab8500-pwm"), > > OF_MFD_CELL("ab8500-pwm", > NULL, NULL, 0, 0, "stericsson,ab8500-pwm"), > > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 0, "stericsson,ab8500-pwm", 0), > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 1, "stericsson,ab8500-pwm", 1), > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 2, "stericsson,ab8500-pwm", 2), > > >> > >> The only .dts or .dtsi files where I see compatible "stericsson,ab8500-pwm" > >> are: > >> > >> arch/arm/boot/dts/ste-ab8500.dtsi > >> arch/arm/boot/dts/ste-ab8505.dtsi > >> > >> These two .dtsi files only have a single node with this compatible. > >> Chasing back to .dts and .dtsi files that include these two .dtsi > >> files, I see no case where there are multiple nodes with this > >> compatible. > >> > >> So it looks to me like there is no .dts in mainline that is providing > >> the three "stericsson,ab8500-pwm" nodes that drivers/mfd/ab8500-core.c > >> is expecting. No case that there are multiple mfd child nodes where > >> mfd_add_device() would assign the first of n child nodes with the > >> same compatible to multiple devices. > >> > >> So it appears to me that drivers/mfd/ab8500-core.c is currently broken. > >> Am I missing something here? > >> > >> If I am correct, then either drivers/mfd/ab8500-core.c or > >> ste-ab8500.dtsi and ste-ab8505.dtsi need to be fixed. > > > > Your analysis is correct. > > OK, if I'm not overlooking anything, that is good news. > > Existing .dts source files only have one "ab8500-pwm" child. They already > work correcly. > > Create a new compatible for the case of multiple children. In my example > I will add "-mc" (multiple children) to the existing compatible. There > is likely a better name, but this lets me provide an example. > > Modify drivers/mfd/ab8500-core.c to use the new compatible, and new .dts > source files with multiple children use the new compatible: > > OF_MFD_CELL("ab8500-pwm", > NULL, NULL, 0, 0, "stericsson,ab8500-pwm"), > > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 0, "stericsson,ab8500-pwm", 0), > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 1, "stericsson,ab8500-pwm", 1), > OF_MFD_CELL_REG("ab8500-pwm-mc", > NULL, NULL, 0, 2, "stericsson,ab8500-pwm", 2), > > The "OF_MFD_CELL" entry is the existing entry, which will handle current > .dts source files. The new "OF_MFD_CELL_REG" entries will handle new > .dts source files. Sorry, but I'm not sure what the above exercise is supposed to solve. Could you explain it for me please? > And of course the patch that creates OF_MFD_CELL_REG() needs to precede > this change. > > I would remove the fallback code in the existing patch that tries to > handle an incorrect binding. Just error out if the binding is not > used properly. What fallback code? > > Although it's not "broken", it just works when it really shouldn't. > > > > I will be fixing the 'ab8500-pwm' case in due course. > > > >> Moving forward, your proposed OF_MFD_CELL_REG() method seems a good > >> approach (I have not completely read the actual code in the patch yet > >> though). > > > > Thanks. > > > -- Lee Jones [李琼斯] Senior Technical Lead - Developer Services Linaro.org │ Open source software for Arm SoCs Follow Linaro: Facebook | Twitter | Blog