Hello. On 24-04-2014 14:26, Geert Uytterhoeven wrote:
Add helpers pm_generic_runtime_clk_suspend() and pm_generic_clk_runtime_resume(), combining generic runtime PM and generic clock PM.
Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
[...]
diff --git a/include/linux/pm_clock.h b/include/linux/pm_clock.h index 6981aa288c45..bf1e4d09a0ca 100644 --- a/include/linux/pm_clock.h +++ b/include/linux/pm_clock.h @@ -35,6 +35,8 @@ extern int pm_clk_add_clk(struct device *dev, struct clk *clk); extern void pm_clk_remove(struct device *dev, const char *con_id); extern int pm_clk_suspend(struct device *dev); extern int pm_clk_resume(struct device *dev); +extern int pm_generic_runtime_clk_suspend(struct device *dev); +extern int pm_generic_clk_runtime_resume(struct device *dev);
Shouldn't these function names be symmetric? I think '_clk' and '_runtime' need swapping in one case.
WBR, Sergei -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html