Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Apr 03, 2019 at 01:03:17PM +0000, Wen He wrote:
> 
> 
> > -----Original Message-----
> > From: Shawn Guo [mailto:shawnguo@xxxxxxxxxx]
> > Sent: 2019年4月3日 18:14
> > To: Wen He <wen.he_1@xxxxxxx>
> > Cc: devicetree@xxxxxxxxxxxxxxx; Leo Li <leoyang.li@xxxxxxx>;
> > liviu.dudau@xxxxxxx; brian.starkey@xxxxxxx
> > Subject: Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500
> > node
> > 
> > On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
> > > The LS1028A has a LCD controller and Displayport interface that
> > > connects to eDP and Displayport connectors on the LS1028A board.
> > >
> > > This patch enables the LCD controller driver on the LS1028A.
> > >
> > > Signed-off-by: Alison Wang <alison.wang@xxxxxxx>
> > > Signed-off-by: Wen He <wen.he_1@xxxxxxx>
> > > ---
> > >  .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37
> > > +++++++++++++++++++
> > >  1 file changed, 37 insertions(+)
> > >
> > > diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
> > > b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
> > > index 8dd3501b1333..0d5963bb46c5 100644
> > > --- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
> > > +++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
> > > @@ -70,6 +70,27 @@
> > >  		clock-output-names = "sysclk";
> > >  	};
> > >
> > > +	dpclk: dpclk {
> > 
> > Please follow the naming convention "clock-xxx".
> > 
> > > +		compatible = "fixed-clock";
> > > +		#clock-cells = <0>;
> > > +		clock-frequency = <27000000>;
> > > +		clock-output-names= "dpclk";
> > > +	};
> > > +
> > > +	aclk: aclk {
> > > +		compatible = "fixed-clock";
> > > +		#clock-cells = <0>;
> > > +		clock-frequency = <650000000>;
> > > +		clock-output-names= "aclk";
> > > +	};
> > > +
> > > +	pclk: pclk {
> > > +		compatible = "fixed-clock";
> > > +		#clock-cells = <0>;
> > > +		clock-frequency = <650000000>;
> > > +		clock-output-names= "pclk";
> > > +	};
> > > +
> > >  	reboot {
> > >  		compatible ="syscon-reboot";
> > >  		regmap = <&dcfg>;
> > > @@ -433,4 +454,20 @@
> > >  			};
> > >  		};
> > >  	};
> > > +
> > > +	dp0: malidp@f080000 {
> > 
> > The node name should be something generic.  The recommendation from
> > Devicetree Specification is 'display'.
> > 
> 
> That definition following by malidp Devicetree bindings file.
> If use name is 'display', how to define display port controller? this only is LCD controller dts node.

We can use some sort of suffix to define multiple nodes:

 - display-0, display-1 ...
 - display-dp, display-lcd, ...

Whatever suffix works for you, but begin with a generic name.

> 
> > > +		compatible = "arm,mali-dp500";
> > > +		reg = <0x0 0xf080000 0x0 0x10000>;
> > > +		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
> > > +			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
> > > +		interrupt-names = "DE", "SE";
> > > +		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
> > > +		clock-names = "pxlclk", "mclk", "aclk", "pclk";
> > > +		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
> > 
> > Please have a newline between properties and child node.
> > 
> > Shawn
> > 
> 
> Sure, but I see the mail devicetree binding doesn't have a blank line. So I removed it.
> Is need to add a newline?

Different bindings use different conventions, but we have a set of
conventions for devicetree sources I maintain.

Shawn



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux