On 2/2/19 3:12 PM, Fabio Estevam wrote:
On Sat, Feb 2, 2019 at 7:59 PM Martin Kelly <martin@xxxxxxxxxxxxxxxx> wrote:
From: Martin Kelly <martin@xxxxxxxxxxxxxxxx>
We are using "if (ret < 0)" in many places in which the function returns 0
on success. Use "if (ret)" instead for better clarity and correctness.
What's wrong with "if (ret < 0)" ?
Jonathan Cameron pointed out that the check is for functions that return
0 on success. Thus, the check should be either "if (ret != 0)" or "if
(ret)". Jonathan prefers "if (ret)", so I'm using that. By leaving it at
"if (ret < 0)", technically a function could return positive numbers and
not count as an error, which is a bug.