From: Levin Du <djw@xxxxxxxxxxxxx> Adding a GRF GPIO controller labled "grf_gpio" to rk3328, currently providing access to the GPIO_MUTE pin, which is manupulated by the GRF_SOC_CON10 register. The GPIO_MUTE pin is referred to as <&grf_gpio 0>. Signed-off-by: Levin Du <djw@xxxxxxxxxxxxx> --- Changes in v4: - Use binding of "rockchip,rk3328-grf-gpio" Changes in v3: - Use dedicated "rockchip,rk3328-gpio-mute" driver Changes in v2: - Rename gpio_syscon10 to gpio_mute in rk3328.dtsi Changes in v1: - Split from V0 and add to rk3328.dtsi for general use. arch/arm64/boot/dts/rockchip/rk3328.dtsi | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi index 3f5a294..bf5656d 100644 --- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi +++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi @@ -275,6 +275,12 @@ mode-loader = <BOOT_BL_DOWNLOAD>; }; + grf_gpio: grf-gpio { + compatible = "rockchip,rk3328-grf-gpio"; + gpio-controller; + #gpio-cells = <2>; + status = "disabled"; + }; }; uart0: serial@ff110000 { -- 2.7.4 -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html