From: Sean Wang <sean.wang@xxxxxxxxxxxx> It's unnecessary doing irq_dispose_mapping as a reverse operation for platform_get_irq. Ususally, irq_dispose_mapping should be called in error path or module removal to release the resources for irq_of_parse_and_map requested. Signed-off-by: Sean Wang <sean.wang@xxxxxxxxxxxx> --- drivers/rtc/rtc-mt6397.c | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git a/drivers/rtc/rtc-mt6397.c b/drivers/rtc/rtc-mt6397.c index b62eaa8..cefb83b 100644 --- a/drivers/rtc/rtc-mt6397.c +++ b/drivers/rtc/rtc-mt6397.c @@ -17,7 +17,6 @@ #include <linux/module.h> #include <linux/regmap.h> #include <linux/rtc.h> -#include <linux/irqdomain.h> #include <linux/jiffies.h> #include <linux/platform_device.h> #include <linux/of_address.h> @@ -336,7 +335,7 @@ static int mtk_rtc_probe(struct platform_device *pdev) if (ret) { dev_err(&pdev->dev, "Failed to request alarm IRQ: %d: %d\n", rtc->irq, ret); - goto out_dispose_irq; + return ret; } device_init_wakeup(&pdev->dev, 1); @@ -353,8 +352,7 @@ static int mtk_rtc_probe(struct platform_device *pdev) out_free_irq: free_irq(rtc->irq, rtc->rtc_dev); -out_dispose_irq: - irq_dispose_mapping(rtc->irq); + return ret; } @@ -364,7 +362,6 @@ static int mtk_rtc_remove(struct platform_device *pdev) rtc_device_unregister(rtc->rtc_dev); free_irq(rtc->irq, rtc->rtc_dev); - irq_dispose_mapping(rtc->irq); return 0; } -- 2.7.4 -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html