On Friday 29 November 2013, Jonas Jensen wrote: > Add GPIO driver for MOXA ART SoCs. > > Signed-off-by: Jonas Jensen <jonas.jensen@xxxxxxxxx> Acked-by: Arnd Bergmann <arnd@xxxxxxxx> One more comment, no need to resend for another review if this is the only thing you want to change: > +struct moxart_gpio_chip { > + struct gpio_chip gpio; > + void __iomem *moxart_gpio_base; > +}; If you rename 'moxart_gpio_base' to 'base' > +static int moxart_gpio_get(struct gpio_chip *chip, unsigned offset) > +{ > + struct moxart_gpio_chip *gc = to_moxart_gpio(chip); > + u32 ret = readl(gc->moxart_gpio_base + GPIO_PIN_DIRECTION); > + > + if (ret & BIT(offset)) > + return !!(readl(gc->moxart_gpio_base + GPIO_DATA_OUT) & > + BIT(offset)); > + else > + return !!(readl(gc->moxart_gpio_base + GPIO_DATA_IN) & > + BIT(offset)); > +} These will fit in one line with no loss of readability. Arnd -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html