Re: [PATCH] pwm: renesas-tpu: Add DT support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




Hi Thierry,

On Monday 12 August 2013 09:21:58 Thierry Reding wrote:
> On Thu, Aug 08, 2013 at 12:44:42PM +0200, Laurent Pinchart wrote:
> > Hi Thierry,
> > 
> > I'd like to get this patch in v3.12, could you please take it in your tree
> > ?
>
> I'm Cc'ing the device tree bindings maintainers. Given that this uses
> only the standard PWM bindings in the first place I suppose it would be
> okay to take this in, but I'd like to run it past them to make sure.
> 
> > On Friday 26 July 2013 00:27:41 Laurent Pinchart wrote:
> > > Specify DT bindings for the TPU PWM controller and add OF support to the
> > > driver.
> > > 
> > > Signed-off-by: Laurent Pinchart
> > > <laurent.pinchart+renesas@xxxxxxxxxxxxxxxx>
> > > ---
> > > 
> > >  .../devicetree/bindings/pwm/renesas,tpu-pwm.txt    | 28 +++++++++++++++
> > >  drivers/pwm/pwm-renesas-tpu.c                      | 41 +++++++++++----
> > >  2 files changed, 62 insertions(+), 7 deletions(-)
> > >  create mode 100644
> > > 
> > > Documentation/devicetree/bindings/pwm/renesas,tpu-pwm.txt
> > > 
> > > This patch depends on the "[PATCH v2 0/4] Add PWM polarity flag macro
> > > for DT" series that is scheduled for merge in the PWM tree, and should
> > > thus go in via the same tree.
> > > 
> > > The code has been tested on an Armadillo800EVA with additional platform
> > > patches that I'm going to submit next.

[snip]

> > > diff --git a/drivers/pwm/pwm-renesas-tpu.c
> > > b/drivers/pwm/pwm-renesas-tpu.c
> > > index 2600892..3eeffff 100644
> > > --- a/drivers/pwm/pwm-renesas-tpu.c
> > > +++ b/drivers/pwm/pwm-renesas-tpu.c

[snip]

> > >  static struct platform_driver tpu_driver = {
> > >  	.probe		= tpu_probe,
> > >  	.remove		= tpu_remove,
> > >  	.driver		= {
> > >  		.name	= "renesas-tpu-pwm",
> > >  		.owner	= THIS_MODULE,
> > > +		.of_match_table = of_match_ptr(tpu_of_table),
> 
> I'd like to point this out as an example of why I think aligning on the
> = here is a bad idea. Eventually you're bound to add a field which is
> longer than all the others and therefore can't be aligned consistently.
> So instead of coming up with some kind of fancy formatting it often
> turns out better to just use a regular single space around =. That you
> can always consistently use, no matter how long the field names are.

Thanks, I'll keep that in mind.
 
> To be clear, I don't expect you to change the patch because of this.

OK.

-- 
Regards,

Laurent Pinchart

Attachment: signature.asc
Description: This is a digitally signed message part.


[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]
  Powered by Linux