ninja/cmake stuck at downloading boost during build

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi all,

I am trying to build Ceph binaries from the main branch. Sometimes
"ninja -j 7 " (see the bottom for steps I run to initiate the build)
gets stuck at the step where the Boost library is downloaded. The step
description printed on stdout is "Performing download step (download,
verify and extract) for 'Boost'". Running nethogs shows that cmake is
indeed downloading but the download speed is less than 50 Kbps. Last
night, I also saw this issue while building binaries for the "quincy"

Cancelling and reinitiating the build has no effect on the download
speed. Is there a way to choose the faster/fastest mirror to download
the Boost library? How can I change the default mirror that cmake

Another option is to use the boost library installed on my system. For
this I can pass "-DWITH_SYSTEM_BOOST=ON" to the "" script.
My system has version 1.76 installed. Will this version work fine? Has
anyone tried this before?

I don't face this issue all the time. It happens once in a couple
months but whenever it does, I am stuck for several hours.

System I am using is Fedora 36. Following are the commands I usually
run to initiate building of Ceph binaries -

$ sudo ./
$ cd build
$ ninja -j 7

- Rishabh
Dev mailing list -- dev@xxxxxxx
To unsubscribe send an email to dev-leave@xxxxxxx

[Index of Archives]     [CEPH Users]     [Ceph Devel]     [Ceph Large]     [Information on CEPH]     [Linux BTRFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux