Axis C++ in SASL plugin

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi All,

I tried calling a web service using Axis C++ from plain.c ( a modified mechanism, I added a piece of code to call a webservice in plain.c ). I added the .c stub files generated by Axis C++ and library files to the make file in plugins directory. It got compiled properly and the,, got generated successfuly. But after adding the generated .so files to /lib64/sasl2 directory I couldnt get the mechanism name PLAIN when I give the command "sasl2-shared-mechlist".

But I coomented the added piece of code in plain.c and recompiled and added the .so files, It works fine. ( i.e I get the mechanism name "PLAIN" with the command "sasl2-shared-mechlist" ). What would be the problem. My webservice code works fine when I run it seperately, but when I tried integrating it to the plain.c its not working? Do I need to do anything else to make this work? Is it possible to call a webservice from a customised mechanism?

Please provide your valuable solutions.....


[Index of Archives]     [Info Cyrus]     [Squirrel Mail]     [Linux Media]     [Yosemite News]     [gtk]     [KDE]     [Gimp on Windows]     [Steve's Art]

  Powered by Linux