On 15/04/2014 08:32 πμ, Viresh Kumar wrote: > On 15 April 2014 02:38, Stratos Karafotis <stratosk@xxxxxxxxxxxx> wrote: >> The cpufreq core supports the cpufreq_for_each_entry macro helper >> for iteration over the cpufreq_frequency_table, so use it. >> >> It should have no functional changes. >> >> Signed-off-by: Stratos Karafotis <stratosk@xxxxxxxxxxxx> >> --- >> drivers/cpufreq/acpi-cpufreq.c | 10 +++++----- >> 1 file changed, 5 insertions(+), 5 deletions(-) >> >> diff --git a/drivers/cpufreq/acpi-cpufreq.c b/drivers/cpufreq/acpi-cpufreq.c >> index 000e4e0..12a5750 100644 >> --- a/drivers/cpufreq/acpi-cpufreq.c >> +++ b/drivers/cpufreq/acpi-cpufreq.c >> @@ -213,7 +213,7 @@ static unsigned extract_io(u32 value, struct acpi_cpufreq_data *data) >> >> static unsigned extract_msr(u32 msr, struct acpi_cpufreq_data *data) >> { >> - int i; >> + struct cpufreq_frequency_table *pos; >> struct acpi_processor_performance *perf; >> >> if (boot_cpu_data.x86_vendor == X86_VENDOR_AMD) >> @@ -223,11 +223,11 @@ static unsigned extract_msr(u32 msr, struct acpi_cpufreq_data *data) >> >> perf = data->acpi_data; >> >> - for (i = 0; data->freq_table[i].frequency != CPUFREQ_TABLE_END; i++) { >> - if (msr == perf->states[data->freq_table[i].driver_data].status) >> - return data->freq_table[i].frequency; >> + cpufreq_for_each_entry(pos, data->freq_table) { >> + if (msr == perf->states[pos->driver_data].status) >> + return pos->frequency; >> } >> - return data->freq_table[0].frequency; >> + return data->freq_table->frequency; > > This isn't a related change, isn't it? Also it make it less readable. > So probably > just leave it as is. > I thought that since we use pointer notation it would be more clear. But, I will change it according to your suggestion. Stratos -- To unsubscribe from this list: send the line "unsubscribe cpufreq" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html