On 31 March 2013 07:16, Rafael J. Wysocki <rjw@xxxxxxx> wrote: > On Sunday, March 31, 2013 07:03:04 AM Viresh Kumar wrote: >> On 31 March 2013 03:31, Rafael J. Wysocki <rjw@xxxxxxx> wrote: >> > Sorry, I won't apply this. It changes too much stuff at a time and I'm not >> > really sure if the change being made is necessary. >> >> Hmm.. I thought it is important as it puts the real meaning of "index" in the >> code. > > And what does that change, really? What about documenting the meaning of > "index" instead? Probably not the logic but perception. People don't necessarily go through Documentation but code for writing new stuff. And so code should reflect the real meaning. In case we write something like following in documentation: "Index: This is driver specific data for each frequency. Core doesn't use it." Then "Index" looks even more wrong. Its not the right name for any such variable. And so it should be fixed. -- To unsubscribe from this list: send the line "unsubscribe cpufreq" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html