Hi Andrei, On 4/3/2013 10:55 AM, Andrei Belov wrote: >> We spent a huge amount of time moving to "detect features" vs >> "hardcoding" because it´s a lot more flexible and lasts longer. this >> approach is moving backwards. > > Thanks for the explanation - I see why this makes sense now. > > Please find the improved patch attached. I've just tested it on CentOS 6.0, > SunOS 5.11 and Mac OS X 10.8.3, and it seems to work as expected. > > GCC versions are below: > > CentOS: gcc version 4.4.4 20100726 (Red Hat 4.4.4-13) (GCC) > SunOS: gcc version 4.7.2 (GCC) > Mac OS X: gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00) > > Much better patch, only a few minor bits: +if test "$ap_cv_cc_as_needed" = "yes"; then + SEC_LDFLAGS="$SEC_LDFLAGS -Wl,--as-needed" +fi please don´t overload SEC_LDFLAGS. SEC stands for SECURITY (see other configure.ac bits related). At that stage of the check you can simply add it to LD_FLAGS if it´s supported. For the --version-script: Please rename EXTRA_LDFLAGS to something more specific. Maybe VERSCRIPT_LDFLAGS or something like that. this is merely to avoid conflict with those distribution automatic build system that override default LD_FLAGS via EXTRA_LDFLAGS and such, and to keep the variable isolated. Nice work btw! Thanks! Fabio _______________________________________________ discuss mailing list discuss@xxxxxxxxxxxx http://lists.corosync.org/mailman/listinfo/discuss