Re: RBD mirroring to an EC pool

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On the other hand, the openstack docs [3] report this:

The mirroring of RBD images stored in Erasure Coded pools is not currently supported by the ceph-rbd-mirror charm due to limitations in the functionality of the Ceph rbd-mirror application.

But I can't tell if it's a limitation within the charm or in general.


Zitat von Eugen Block <eblock@xxxxxx>:


I think you still need a replicated pool for the rbd metadata, check out this thread [1]. Althouh I don't know if a mixed setup will work. IIUC, in the referred thread the pools are set up identically on both clusters, not sure if it will work if you only have one replicated pool in site A while site B has two pools (replicated for metadata and EC for data). But according to [2] the rbd-mirror it might be possible:

When creating images in the destination cluster, rbd-mirror selects a data pool as follows: 1. If the destination cluster has a default data pool configured (with the rbd_default_data_pool configuration option), it will be used. 2. Otherwise, if the source image uses a separate data pool, and a pool with the same name exists on the destination cluster, that pool will be used.
3.   If neither of the above is true, no data pool will be set.

But it's worth a shot, I guess.



Zitat von Jan Kasprzak <kas@xxxxxxxxxx>:

Hello, Ceph users,

I would like to use my secondary Ceph cluster for backing up RBD OpenNebula
volumes from my primary cluster using mirroring in image+snapshot mode.
Because it is for backups only, not a cold-standby, I would like to use
erasure coding on the secondary side to save a disk space.
Is it supported at all?

I tried to create a pool:

secondary# ceph osd pool create one-mirror erasure k6m2
secondary# ceph osd pool set one-mirror allow_ec_overwrites true
set pool 13 allow_ec_overwrites to true
secondary# rbd mirror pool enable --site-name secondary one-mirror image
2024-02-02T11:00:34.123+0100 7f95070ad5c0 -1 librbd::api::Mirror: mode_set: failed to allocate mirroring uuid: (95) Operation not supported

When I created a replicated pool instead, this step worked:

secondary# ceph osd pool create one-mirror-repl replicated
secondary# rbd mirror pool enable --site-name secondary one-mirror-repl image

So, is RBD mirroring supported with erasure-coded pools at all? Thanks!


| Jan "Yenya" Kasprzak <kas at { - work | - private}> |
|                        GPG: 4096R/A45477D5 |
   We all agree on the necessity of compromise. We just can't agree on
   when it's necessary to compromise.                     --Larry Wall
ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux