Re: RBD Image Returning 'Unknown Filesystem LVM2_member' On Mount - Help Please

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Mounting/Mapping commands:

`rbd device map data_pool/data_pool_image_1 --id rbd_user --keyring /etc/ceph/ceph.client.rbd_user.keyring`

`mount /dev/rbd0 /mountpoint/rbd_data`

data_pool is showing up in a lsblk command as mapped to /dev/rbd0:


NAME                             MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS

rbd0                                 252:0      0          8T  0     disk


*Yes, its an 8 TB "disk" - lot of space for bulk files - in truth, its probably "overkill" but if you've got that much space...  :-)

On 05/02/2024 17:43, Curt wrote:
Out of curiosity, how are you mapping the rbd? Have you tried using guestmount?

I'm just spitballing, I have no experience with your issue, so probably not much help or useful.

On Mon, 5 Feb 2024, 10:05 duluxoz, <duluxoz@xxxxxxxxx> wrote:

    I think that /dev/rbd* devices are flitered "out" or not filter
    "in" by the fiter
    option in the devices section of /etc/lvm/lvm.conf.
    So pvscan (pvs, vgs and lvs) don't look at your device.

    Hi Gilles,

    So the lvm filter from the lvm.conf file is set to the default of
    `filter = [ "a|.*|" ]`, so that's accept every block device, so no
    luck there  :-(

    For Ceph based LVM volumes, you would do this to import:
    Map every one of the RBDs to the host
    Include this in /etc/lvm/lvm.conf:
    types = [ "rbd", 1024 ]
    If you see the VG:
    vgimportclone -n <make a name for VG> /dev/rbd0 /dev/rbd1 ... --import
    Now you should be able to vgchange -a y <your VG> and see the LVs

    Hi Alex,

    Did the above as you suggested - the rbd devices (3 of them, none
    of which were originally part of an lvm on the ceph servers - at
    least, not set up manually by me) still do not show up using
    pvscan, etc.

    So I still can't mount any of them (not without re-creating a fs,
    anyway, and thus losing the data I'm trying to read/import) - they
    all return the same error message (see original post).

    Anyone got any other ideas? <hopeful tone in voice>  :-)


    ceph-users mailing list -- ceph-users@xxxxxxx
    To unsubscribe send an email to ceph-users-leave@xxxxxxx

Peregrine IT Signature

*Matthew J BLACK*
  M.Inf.Tech.(Data Comms)
  MACS (Snr), CP, IP3P

When you want it done /right/ ‒ the first time!

Phone: 	+61 4 0411 0089
Email: 	matthew@xxxxxxxxxxxxxxx <mailto:matthew@xxxxxxxxxxxxxxx>
Web: <>

View Matthew J BLACK's profile on LinkedIn <>

This Email is intended only for the addressee.  Its use is limited to that intended by the author at the time and it is not to be distributed without the author’s consent.  You must not use or disclose the contents of this Email, or add the sender’s Email address to any database, list or mailing list unless you are expressly authorised to do so.  Unless otherwise stated, Peregrine I.T. Pty Ltd accepts no liability for the contents of this Email except where subsequently confirmed in writing.  The opinions expressed in this Email are those of the author and do not necessarily represent the views of Peregrine I.T. Pty Ltd.  This Email is confidential and may be subject to a claim of legal privilege.

If you have received this Email in error, please notify the author and delete this message immediately.
ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux